ENG New site

Advanced search

[ New messages · Forum rules · Members ]
  • Page 1 of 1
  • 1
Forum » SpaceEngine » Troubleshooting and Solutions » Planet Problems and Crashing 2 (Further Notes)
Planet Problems and Crashing 2
sviatogorDate: Wednesday, 31.07.2013, 18:19 | Message # 1
Group: Newbies
United Kingdom
Messages: 3
Status: Offline
I got no replies to my post "Planet problems and Crashing" which slightly
surprised me. Blurry textures had been reported for Solar System planets but
no one seem to have reported no textures at all! In fact I have since found
that as the program loads some planets, ie. Earth, Moon, Mars, Mercury,
Pluto,Uranus, I see a flash of a texture then it goes black with only the
white atmosphere rim showing. However some other planets do show up -
Venus,Jupiter,Neptune,Titan, Triton, though not all the moons and asteroids.
Some other gas planets and comets dont show. So far I have found a fair
number of detailed procedural planets do show up. All this using version

However here is my rather strange workround. I went backwards and downloaded
version 0.96 and discovered that it worked better for me. All the main Solar
System planets were there. And the procedural ones too. However I still
discovered a few blanks - some gas planets, moons and asteroids. In
general it works better, though obviously some nebula graphics are better in
v.0.97. I skipped the v.0.96 patch as it made things worse again.

Regards crashing. For me v.0.97 is much more prone to crashing than v.0.96.
I spent a good bit of time experimenting with the procedural planets in both
and found that there is a delicate balance. Descend too low onto (say) a
complex ice planet at full graphics quality (2) and make sudden radical
movements with the mouse and it crashes. Slightly higher, nice and slow
doesn't put such a heavy sudden load on the system and prevents this. This
is slightly similiar to rendering at ground level on some complex procedural
terrains in the planet generator Mojoworld (computer cant handle it and
rendering stops). Unlike MojoWorld Space Engine renders procedural terrains
not as a separate process but there and then while one is still inputting
data. This interferes with rendering and overloads the system. I know one
can turn down the quality but of course we all want the best quality.

Which is my conclusion - problems with Space Engine is not always
necessarily the program but the computer power - my Nvidia 1024mb graphics
card, 3.10 GHz cpu and 4GB memory and Open GL 4.1 might sound okay but its
on the edge for Space Engine. On the download page it says that the
recommended system requirements are:

Video 1024MB
OpenGL 3.0
HDD Space 10GB
Windows 7

With due respect this is not enough. Space Engine is a power hungry creature
and this specification need to be raised.

Happily I must report that Space Engine is so good that I am prepared to put
up with the problems, especially now that I understand them better, and will
be using both versions 0.96 and 0.97. in order to get full coverage. I have
tried interchanging some features (eg) there are more nebulas in v.0.97. But
without success. Not surprisingly as I dont really know what I am doing and
tinkering is sometimes not enough.

Please excuse the rambling nature of this post. It would be nice hear
anyone's comments. Harbinger Dawn what do you think?
Billy_MayesDate: Wednesday, 31.07.2013, 19:11 | Message # 2
Group: Users
Messages: 485
Status: Offline
Have you taken a look at the troubleshooting thread?

Other than that I have no idea how to fix this.
Have you tampered with the SpaceEngine files?

AMD Phenom II X4 955 3.2 GHz Quad-Core - AMD Radeon HD 6950 2GB VRAM - 4GB RAM - 1680x1050 75 Hz Samsung screen
sviatogorDate: Wednesday, 31.07.2013, 22:01 | Message # 3
Group: Newbies
United Kingdom
Messages: 3
Status: Offline
Yes I did all the things suggested on the troubleshooting page such as taking the graphic quality down to -2, switching off 3D water etc etc.

I went to Nvidia and manually searched and did find an update on my graphics card driver. So far this has not been installed because the computer told me that the driver I already have is the correct one for the system. This even after I allowed Windows to then automatically search for updates. It would have found that relevent update but still did not begin an automatic download and install. So I did nothing thinking the computer possibly knew best. I'm not keen to tamper as I had a bad experience with updates on a previous computer. If anyone has any advice on this I would interested to hear.

No I didn't tamper with Space Engine files to begin with - the non-textured planets were like that from the first moment the program came up on screen. I have "fiddled" since - not that it has made any difference - though I always return files or .cfg entries to the way they were originally if I did not get a result. Which has been never.

As someone mentioned - we all have different systems, and I suppose it stands to reason that code will not always work perfectly in conjunction with so many individual foibles and flaws inherent in so much varied hardware. The question is - can one put up with it as it is? Is the software worth it? My answer is - definitely YES!
NielzDate: Monday, 05.08.2013, 20:12 | Message # 4
Space Tourist
Group: Users
Messages: 29
Status: Offline
I am experiencing crashes too, but rather when I am moving through space at extreme speeds for a while (those speeds where stars look blurred like "beams" when you fly by them)

Added (05.08.2013, 12:36)
I've changed the LoaderMode as describe in the troubleshooter's guide and the crashes while moving interstellar seemed to have resolved. But now I do get forced application closed due to low-memory, which is a little bit strange as I have 8 Gb of RAM and usually only 25% is in use when I start SE, and SE itself only takes up around 1.5 Gb of RAM when the low memory warning comes up.
So i'd have 75% of memory free when I start SE, which is about 6 Gb. If SE only uses up to about 1.5 - 1.8 Gb, I'd still have 4.2 Gb's of free RAM. I don't know what's happening here. I do have the pagefile disabled, but I doubt that is the problem since I have an abundance of memory. Could it be that SE has a memory leak of some sort?

Added (05.08.2013, 23:12)
Well, I've enable the page file again, and no crashes or low-memory warnings so far.

Forum » SpaceEngine » Troubleshooting and Solutions » Planet Problems and Crashing 2 (Further Notes)
  • Page 1 of 1
  • 1