ENG New site

Advanced search

[ New messages · Forum rules · Members ]
Page 2 of 3«123»
Forum » SpaceEngine » Archive » Troubleshooting - SpaceEngine 0.93
Troubleshooting - SpaceEngine 0.93
SpaceEngineerDate: Friday, 27.05.2011, 19:13 | Message # 16
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4800
Status: Offline
Thanks, I looked at your log and found the problem. This is overflow of loader request queue, it is only 1024 items long. You were probably at core of galaxy or moved or rotated too quickly. So loader queue was fully loaded and many requests for textures were ignored. I've fixed this by increasing the queue size, so in the next version this should not appear anymore.

I found another bug in your log - error loading MilkyWay galaxy model. This is probably because you installed 0.93 version over the older 0.90 version, and did not delete the cache folder. Right? Delete the cache folder located in main SpaceEngine folder, or make a new clean installation of 0.93.

*





 
j0KeRDate: Friday, 27.05.2011, 19:26 | Message # 17
Explorer
Group: Users
Greece
Messages: 178
Status: Offline
Quote (SpaceEngineer)
You were probably at core of galaxy or moved or rotated too quickly. So loader queue was fully loaded and many requests for textures were ignored


Yeah, that, you found the correct phrase to express it smile

Quote (SpaceEngineer)
This is probably because you installed 0.93 version over the older 0.90 version, and did not delete the cache folder. Right? Delete the cache folder located in main SpaceEngine folder, or make a new clean installation of 0.93.


I did a clean install of 0.93 SE i didn't install over 0.90 smile

*





"Novus Ordo Seclorum"

Intel Core(E6850) 2 Duo 3.00 GHz \ Geforce GTX560 1024MB \ 4GB 667(MHz) 2 Channel RAM \ Windows 7 (32bit) \ Samsung SA700D 120hz (3D)
 
NeonDate: Saturday, 28.05.2011, 00:36 | Message # 18
Explorer
Group: SE team
Australia
Messages: 208
Status: Offline
I think I didn't when I had a problem n had to reinstall. I just
reinstalled over the top of the old one. Tch tch tch lol
 
SpaceEngineerDate: Saturday, 28.05.2011, 21:25 | Message # 19
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4800
Status: Offline
When you install a new version, it is better to remove the old cache folder. The new version may have some changes in the shaders, so if there are old shaders in the cache, then the program will load those and stop it working correctly. If there is a new version available, then it is better to do a clean install, but delete the cache before installation.

*





 
NeonDate: Saturday, 28.05.2011, 22:20 | Message # 20
Explorer
Group: SE team
Australia
Messages: 208
Status: Offline
Ahh ok thanks... so just delete / uninstall the old vers before installing new one. Got it. smile
 
NeonDate: Wednesday, 08.06.2011, 14:32 | Message # 21
Explorer
Group: SE team
Australia
Messages: 208
Status: Offline
Hey Vova,

I've experienced lately in 0.93 problems with the camera. Set off
for a star manually all is fine until I see something n want to change
direction. When I click on a new object, center it n go there,
the camera adopts a drift down, even though before moving off
it was completely stopped. As you close on this new object,
constantly making corrections for the drift and constant recentering, when
you get say into an open cluster, the drift turns into a rotation around
the objectt, and the last wierd thing is mouse rotation with mouse btn 1 & 2
no long work at all.

Except for the mb1 n mb2 problem, the rest can be corrected by
hitting G to go there most times,sometims when it doesn't you get
this wierd rotation effect.

Fixed in 0.94???
 
SpaceEngineerDate: Wednesday, 08.06.2011, 16:09 | Message # 22
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4800
Status: Offline
Hi,

I don't understand what you're saying. Inaccurate binding of camera to object, that causes offset of rotation center? This is usually happens when you fly with autopilot ('G') to planet in some other solar system. It can be fixed by hitting 'G' again, as you rightly say. I still have not fixed it.

*





 
NeonDate: Friday, 10.06.2011, 17:46 | Message # 23
Explorer
Group: SE team
Australia
Messages: 208
Status: Offline
I'm not sure what causes it, it's seems to occur after you've manually
travelled to a few different places, and selected a few different objects.
It then develops this drift that just can't be stopped except with the G key.
You can counter it manually, but there's just no way to completely stop it.
Why the Z key stops working is beyond me.
 
SpaceEngineerDate: Saturday, 11.06.2011, 10:51 | Message # 24
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4800
Status: Offline
Are you talking about continuous flight that can't be stopped?

You can be locked relative to some planet and move/rotate with it. So if you fly manually far away you can still be locked to that planet. Press Shift-D to free camera from planet, or select other planet and press Shift-F to lock onto it.

Another possibility is sticking of a movement key. If some popup window takes focus from SpaceEngine, any key you hold left holded. Hit a key again to release it.





 
NeonDate: Saturday, 11.06.2011, 19:41 | Message # 25
Explorer
Group: SE team
Australia
Messages: 208
Status: Offline
Yes... the camera is continuously flying and can't be stopped except by
hitting G. Yes I know that, and it is locked onto a planet, but using
manual control (not G) after awhile it starts a drift (flying can't be stopped)
in a directon other than I am going. There are no sticking keys,
and there is nothing else loaded.

ie I wish to fly to a star. I lock on, Center © on that star,
and start moving. But camera is drifting (motion other than
direction I want to go) off course, and I have to keep
hitting C to get it back on course. Only way to stop this
is to hit G (something I don't want to do, because I like
to fly manually.
 
TuskinDate: Saturday, 11.06.2011, 21:24 | Message # 26
Space Pilot
Group: Users
Canada
Messages: 94
Status: Offline
maybe you're in Spacecraft or Plane mode. Hit '1'
 
SpaceEngineerDate: Sunday, 12.06.2011, 13:13 | Message # 27
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4800
Status: Offline
I think you were previously "sync rotate" with a rotating planet. So the camera will still rotate with the planet, no matter how far you are away from it. You can stop time by pressing <space>, and that will stop planet rotating.

Or press Shift-D to disable binding of camera to planet before you start to fly away manually.

Maybe I need to introduce auto change of binding mode. For example, when you manually enter atmosphere, the camera automatically switches to "sync rotate" so surface does not move underneath the camera. Then when you leave the planet, the camera switches to "follow" mode, so you can see how the planet slowly rotate under camera. Then when you fly far away from the planet (to another planet or star), the camera switches to free mode (no binding).

This would be for planetarium mode. Then when I make the game eventually, the camera will be binded to the spaceship and follow the ship's physics.

*





 
NeonDate: Sunday, 12.06.2011, 19:57 | Message # 28
Explorer
Group: SE team
Australia
Messages: 208
Status: Offline
I normally have Follow Planet on, maybe encoding within the autopilot
to turn off Follow, track, sync rotation of object when you hit G, or use
the flight keys.

Yes I was in Space Mode which is the mode I usually use. I rarely use
free mode. I'll try that next time I'm in SE
 
TheTraceurDate: Thursday, 14.07.2011, 19:36 | Message # 29
Observer
Group: Newbies
Sweden
Messages: 2
Status: Offline
Hi there! I've been using 0.93 version and it's working fine except one thing; Even though stars, galaxies and so on are turned on, I can't see any in the background. You can see stars while you are very close to them, you can see the sphere and the surface. But you can't see them in the background or any rays from them. Space is completely dark, no stars, dust, galaxies etc.

So how can I solve this? I've been looking for a long time for a solution. No one seems to be getting this problem. I really want to see the milkyway and other stars in the background and not just complete blackness. So is there any way you can solve this?

Shall I provide any information from the config or something?
 
SpaceEngineerDate: Thursday, 14.07.2011, 22:34 | Message # 30
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4800
Status: Offline
Yes, please send me the se.log file. Try to update video card drivers. Try to change stars style ( F4 -> Stars style ).

*





 
Forum » SpaceEngine » Archive » Troubleshooting - SpaceEngine 0.93
Page 2 of 3«123»
Search: