ENG New site

Advanced search

[ New messages · Forum rules · Members ]
Forum » SpaceEngine » Archive » Work progress and public beta test - 0.9.7.4
Work progress and public beta test - 0.9.7.4
parameciumkidDate: Wednesday, 07.10.2015, 23:51 | Message # 586
Explorer
Group: Users
United States
Messages: 277
Status: Offline
It's good reassuring to hear that I'm not the only one having crash-on-startup problems. I really do hope SpaceEngineer is working on this wink
If it's you reading this, any news on whether those links I posted helped? I have a suspicion it's due to one finicky line of code hidden somewhere, perhaps in the menu loading part.

P.S.: My original report was with Patch 5, but this problem still occurs exactly the same way on Patch 6. On what appears to be the same line in fact. In case I didn't post it and it helps, here's a new copy of the crash popup message:

And here's a new SE.log, but as I've mentioned, nothing seems to have changed in it since I tried with Patch 5: se.log
I've tried loads of adjustments to the SE settings, compatibility modes, OS settings including disabling DEP, etc. all with no change whatsoever other than the above message ends up saying "APPCRASH" instead of "BEX".
Also as mentioned previously, when I reopen main.cfg after running SE, I find that the DepthBufferMode is always switched to 1, which according to SE.log, my GPU does not support. Thus my hypothesis is that something is going wrong with SE reverting the file when it shouldn't.
Again, Win7 64-bit with Intel HD Graphics 4000. Patches 1 through 4 worked fine.





Intel HD Graphics 4000 ;P

Edited by parameciumkid - Thursday, 08.10.2015, 00:05
 
SpaceEngineerDate: Thursday, 08.10.2015, 10:00 | Message # 587
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4800
Status: Offline
I probably found the problem with Intel HD, patch will be soon. To bypass that, you may disable reversed z-buffer now in main.cfg:
DepthBufferMode 0
But if it got switched to 1 automatically, it may not help...
Added: Also, dwarf galaxies are fixed now, all of them.





 
gazelleDate: Thursday, 08.10.2015, 10:43 | Message # 588
Astronaut
Group: Users
Korea
Messages: 51
Status: Offline
My SE doesn't work....it crashes when I open it. I installed 0.9.7.4 properly, but it keep crashes! Here is my log file.
Attachments: 5686226.log(0.3 Kb)
 
JackDoleDate: Thursday, 08.10.2015, 11:04 | Message # 589
Star Engineer
Group: Local Moderators
Germany
Messages: 1742
Status: Offline
Quote gazelle ()
My SE doesn't work....it crashes when I open it

Which version of Windows do you have? What graphics card do you have? If you have Windows 10 and a ATI graphics card, you must delete the atioglxx.dll from the SpaceEngine\system directory.





Don't forget to look here.

 
gazelleDate: Thursday, 08.10.2015, 12:14 | Message # 590
Astronaut
Group: Users
Korea
Messages: 51
Status: Offline
I'm window 8, and I use intell HD graphics. Also, it worked well in 0.9.7.3....
 
JackDoleDate: Thursday, 08.10.2015, 12:29 | Message # 591
Star Engineer
Group: Local Moderators
Germany
Messages: 1742
Status: Offline
Quote gazelle ()
I'm window 8, and I use intell HD graphics

Quote SpaceEngineer ()
I probably found the problem with Intel HD, patch will be soon.

Then you have to wait until SpaceEngineer solves the problem ...





Don't forget to look here.

 
gazelleDate: Thursday, 08.10.2015, 13:11 | Message # 592
Astronaut
Group: Users
Korea
Messages: 51
Status: Offline
OHHH!!! It works!!!! Thank you so much!!!
 
parameciumkidDate: Thursday, 08.10.2015, 19:34 | Message # 593
Explorer
Group: Users
United States
Messages: 277
Status: Offline
Quote SpaceEngineer ()
I probably found the problem with Intel HD.

biggrin
Quote SpaceEngineer ()
To bypass that, you may disable reversed z-buffer now in main.cfg:
DepthBufferMode 0
But if it got switched to 1 automatically, it may not help...

cry
Quote SpaceEngineer ()
patch will be soon.

biggrin





Intel HD Graphics 4000 ;P

Edited by parameciumkid - Thursday, 08.10.2015, 19:34
 
PlutonianEmpireDate: Friday, 09.10.2015, 00:08 | Message # 594
Pioneer
Group: Users
United States
Messages: 475
Status: Offline
Quote SpaceEngineer ()
I probably found the problem with Intel HD, patch will be soon. To bypass that, you may disable reversed z-buffer now in main.cfg:
DepthBufferMode 0
But if it got switched to 1 automatically, it may not help...
Added: Also, dwarf galaxies are fixed now, all of them.

Not at first. When it auto-switched back to 1, I loaded it up, got the blank space, quit, re-reset the DepthBufferMode back to 0 made SE work again, so the auto-switch appears to be a one time thing upon first installing. smile

But since you're working on patch, that will be big help. smile





Specs: Dell Inspiron 5547 (Laptop); 8 gigabytes of RAM; Processor: Intel® Core™ i5-4210U CPU @ 1.70GHz (4 CPUs), ~2.4GHz; Operating System: Windows 7 Home Premium 64-bit; Graphics: Intel® HD Graphics 4400 (That's all there is :( )
 
SlamminKhanDate: Friday, 09.10.2015, 14:26 | Message # 595
Observer
Group: Users
United States
Messages: 12
Status: Offline
Quote SpaceEngineer ()
I probably found the problem with Intel HD, patch will be soon. To bypass that, you may disable reversed z-buffer now in main.cfg:
DepthBufferMode 0


I could get past the startup window but when the program was fully loaded and the actual game window popped up it crashed sad

Added (09.10.2015, 14:26)
---------------------------------------------
Is there a way to prevent the program from making the program automatically change the DepthBufferMode to 1?

 
gazelleDate: Friday, 09.10.2015, 15:15 | Message # 596
Astronaut
Group: Users
Korea
Messages: 51
Status: Offline
The Earth, Saturn, Mars, Moon, and Jupiter...(etc) looks strange. Typically the earth looks like a water planet. There are only clouds and water, and it keeps blinking weirdly when I move. This bug was from 0.9.7.3. I think this MUST be fixed right now. cry Here is my log file.
Attachments: 1888848.log(44.6 Kb)
 
JackDoleDate: Friday, 09.10.2015, 16:30 | Message # 597
Star Engineer
Group: Local Moderators
Germany
Messages: 1742
Status: Offline
Found this:

DepthBufferMode 1



DepthBufferMode 0


Maybe the same problem as stars visible behind a black hole.

Attachments: 4176984.jpg(109.6 Kb) · 1295163.jpg(114.2 Kb)





Don't forget to look here.

 
n0b0dyDate: Friday, 09.10.2015, 17:07 | Message # 598
Explorer
Group: Users
Pirate
Messages: 297
Status: Offline
Quote JackDole ()
Found this


This is actually not that bad: it helps navigate when close to black holes.
I agree however that stars visible behind black hole is immersion breaking.
Anyway Space Engineer is aware about all this and a patch will be out soon smile
 
parameciumkidDate: Friday, 09.10.2015, 17:39 | Message # 599
Explorer
Group: Users
United States
Messages: 277
Status: Offline
For anyone interested, my SE installation resets to DepthBufferMode 1 every launch, not just the first one.
The patch is eagerly anticipated.





Intel HD Graphics 4000 ;P
 
JackDoleDate: Friday, 09.10.2015, 18:52 | Message # 600
Star Engineer
Group: Local Moderators
Germany
Messages: 1742
Status: Offline
Quote n0b0dy ()
Anyway Space Engineer is aware about all this and a patch will be out soon

Ahem, but I have no idea what SpaceEngineer already knows or does not know, but I thought that this thread is just there to report bugs. cry
Regarding the pictures, I thought of the orbits, with 'DepthBufferMode 1' they are not curved, as they should be.

Added (09.10.2015, 18:52)
---------------------------------------------

Quote parameciumkid ()
For anyone interested, my SE installation resets to DepthBufferMode 1 every launch, not just the first one.

Make the 'main.cfg' read-only, maybe it helps.





Don't forget to look here.

 
Forum » SpaceEngine » Archive » Work progress and public beta test - 0.9.7.4
Search: