ENG New site

Advanced search

[ New messages · Forum rules · Members ]
Forum » SpaceEngine » Archive » Troubleshooting and bug reports - SpaceEngine 0.9.7.3
Troubleshooting and bug reports - SpaceEngine 0.9.7.3
SpaceEngineerDate: Thursday, 16.04.2015, 22:59 | Message # 1
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4800
Status: Offline
Please post here all of your reports about bugs or crashes in SpaceEngine. Before you post any bugs, please follow these steps:

  • First of all, make sure you updated your video card drivers. This may solve 99% of all isues.
  • Read the Fixing common issues section below. It is possible that your problem can be solved there.
  • Read the List of known issues section below and make sure that your bugs are not on in it. You can use your browser's word finder to help search the list.
  • If the bug is not on the list then please post it in this thread. Attach to your message a screenshot (if possible) and a log file (it's called the se.log and is located in the SpaceEngine/system/ directory). Only the log file will help us to understand your problem and find a solution!



    Fixing videocard-specific issues

    If you do not know which videocard do you have, open the system/se.log file in the text editor and read the Vendor information in the beginning:

    INITIALIZING OPENGL
    [MT] Vendor: ATI Technologies Inc.


    Then look for a solution for you:

    Nvidia: Major lag spikes


    Nvidia: Water missing on terras, clouds are below the surface


    ATI/AMD: Crash on approaching to the black hole, neutron star or white dwarf, on using ship's hyperdrive, or when enabling the Oculus Rift mode or the Fish Eye mode


    ATI/AMD: Crash on Startup on Windows 10


    Intel HD: Glitchy landscape and textures on planets


    Intel HD: Red clouds on Earth




    Fixing common issues

    1) Obsolete or incompatible drivers


    2) Weak system


    3) System with hybrid graphics (NVidia/ATI + Intel HD)


    4) Artifacts on procedural planets


    5) Frequent crashing while generating planetary surface


    6) Spaceship disappears when far from a star


    7) Blurry textures on Solar system planets


    8) Problems with very high resolution displays


    9) Problems in Windows 10 + AMD/ATI




    List of known issues

    Green items have been fixed for the next release

    Not real bugs, but effects caused by limitations in the engine:


    Real bugs:
  •  
    KonsiderDate: Saturday, 13.02.2016, 19:22 | Message # 406
    Observer
    Group: Newbies
    United Kingdom
    Messages: 3
    Status: Offline
    Hi SpaceEngineer,

    Ah yes, I see SE does say that it is not supported and imitation is used. So far I haven't used the 3D projector for any other 3D games but there seems to be no problem when watching 3D movies. I watch the movies with Corel WinDVD Pro but I am not sure of the technical details, sorry. It is such a pity that I cannot use the 3D with NVidia because when it works for a few seconds it is AMAZING! :)

    Thank you so much for your reply and thank you for all your hard work on an awesome program! I may have to change my graphics card just so I can see SE in 3D smile
     
    bzzommboDate: Saturday, 13.02.2016, 22:44 | Message # 407
    Observer
    Group: Users
    Pirate
    Messages: 15
    Status: Offline
    Hello?
     
    BambusmanDate: Saturday, 13.02.2016, 22:56 | Message # 408
    Pioneer
    Group: SE team
    Germany
    Messages: 408
    Status: Offline
    bzzommbo, attach your log file please.
     
    meellis1998Date: Sunday, 14.02.2016, 01:02 | Message # 409
    Observer
    Group: Newbies
    Pirate
    Messages: 6
    Status: Offline
    I keep get this error null 21 null the space engine is 0.972 angry
     
    BambusmanDate: Sunday, 14.02.2016, 11:42 | Message # 410
    Pioneer
    Group: SE team
    Germany
    Messages: 408
    Status: Offline
    meellis1998, look at the main post of this thread under fixing common issues.
    before you post something look at the forum first if there is an already existing post, question or thread...


    Edited by Bambusman - Sunday, 14.02.2016, 13:41
     
    connorneal2005Date: Sunday, 14.02.2016, 13:31 | Message # 411
    Astronaut
    Group: Users
    Pirate
    Messages: 46
    Status: Offline
    I think we could make Hubble classifications better in 0.9.7.4.8

    The galaxy RG 0-0-0-786 seems to have the wrong hubble classification for it's model.

    The galaxy is classed as SBc

    Here's a screenshot



    It should be an Irregular galaxy thought there are Pros and Cons

    ___________________________________________________________



    ___________________________________________________________

    Another problem (!?)

    There is a star that comes way too close to the central black hole that should be getting spaghettificated



    *You are closer than you think*



    So it should have a VERY unstable orbit.

    Why is this?

    EDIT: The black hole is too big for the star to be spaghettified. The gravity is spread out if it is big smile

    Attachments: 9781460.jpg(183.0 Kb) · 5952694.jpg(572.3 Kb) · 3193146.jpg(506.2 Kb) · 7292003.jpg(572.3 Kb)





    How big is the universe?

    Edited by connorneal2005 - Friday, 19.02.2016, 11:42
     
    bzzommboDate: Sunday, 14.02.2016, 17:16 | Message # 412
    Observer
    Group: Users
    Pirate
    Messages: 15
    Status: Offline
    Here is the log. I checked it, nothing about the error, more about succesfully loading launch photo.
    Attachments: 4234282.log(0.2 Kb)
     
    BambusmanDate: Sunday, 14.02.2016, 17:39 | Message # 413
    Pioneer
    Group: SE team
    Germany
    Messages: 408
    Status: Offline
    bzzommbo, the next patch for SpacEngine 0974 will work with windows xp.
     
    bzzommboDate: Sunday, 14.02.2016, 19:07 | Message # 414
    Observer
    Group: Users
    Pirate
    Messages: 15
    Status: Offline
    Quote Bambusman ()
    bzzommbo, the next patch for SpacEngine 0974 will work with windows xp.


    It was said that 0973 would fix the game, eh... Nevermind, I'm looking forward to play the game normally.
     
    opsee_moo5Date: Monday, 15.02.2016, 19:19 | Message # 415
    Observer
    Group: Newbies
    Tunisia
    Messages: 1
    Status: Offline
    hi space engine dont work is my ram is G 4 And i have realy good G.C.
    BUT THE GAME CRASH AND IF I OPEN LOG FILE HIS TELL ME THIS :
    MT] ERROR: Linking shader "system/shaders/atmo_transm.glsl":

    [MT] Loading shader "system/shaders/blackhole_disk.glsl"
    [MT] ERROR: Compiling shader "system/shaders/blackhole_disk.glsl":
    ERROR: 0:1: '' : Version number not supported by OGL driver
    ERROR: 0:1: '' : syntax error #version
    ERROR: 0:17: 'mat4x4' : syntax error parse error
    [MT] ERROR: Compiling shader "system/shaders/blackhole_disk.glsl":
    ERROR: 0:1: '' : Version number not supported by OGL driver
    ERROR: 0:1: '' : syntax error #version
    ERROR: 0:17: 'mat4x4' : syntax error parse error
    [MT] ERROR: Linking shader "system/shaders/blackhole_disk.glsl":

    [MT] Loading shader "system/shaders/blackhole_warp.glsl"
    [MT] ERROR: Compiling shader "system/shaders/blackhole_warp.glsl":
    ERROR: 0:1: '' : Version number not supported by OGL driver
    ERROR: 0:1: '' : syntax error #version
    ERROR: 0:11: 'layout' : syntax error parse error
    [MT] ERROR: Compiling shader "system/shaders/blackhole_warp.glsl":
    ERROR: 0:1: '' : Version number not supported by OGL driver
    ERROR: 0:1: '' : syntax error #version
    ERROR: 0:23: 'in' : supported in GLSL 1.30 or later
    ERROR: 0:24: 'layout' : syntax error parse error
    [MT] ERROR: Linking shader "system/shaders/blackhole_warp.glsl":

    [MT] Loading shader "system/shaders/ship_warp.glsl"
    [MT] ERROR: Compiling shader "system/shaders/ship_warp.glsl":
    ERROR: 0:1: '' : Version number not supported by OGL driver
    ERROR: 0:1: '' : syntax error #version
    ERROR: 0:12: 'layout' : syntax error parse error
    [MT] ERROR: Compiling shader "system/shaders/ship_warp.glsl":
    ERROR: 0:1: '' : Version number not supported by OGL driver
    ERROR: 0:1: '' : syntax error #version
    ERROR: 0:24: 'in' : supported in GLSL 1.30 or later
    ERROR: 0:25: 'layout' : syntax error parse error
    [MT] ERROR: Linking shader "system/shaders/ship_warp.glsl":

    [MT] Loading shader "system/shaders/get_pixel.glsl"
    [MT] ERROR: Compiling shader "system/shaders/get_pixel.glsl":
    ERROR: 0:1: '' : Version number not supported by OGL driver
    ERROR: 0:1: '' : syntax error #version
    ERROR: 0:9: 'layout' : syntax error parse error
    [MT] ERROR: Compiling shader "system/shaders/get_pixel.glsl":
    ERROR: 0:1: '' : Version number not supported by OGL driver
    ERROR: 0:1: '' : syntax error #version
    ERROR: 0:19: 'layout' : syntax error parse error
    [MT] ERROR: Linking shader "system/shaders/get_pixel.glsl":

    [MT] Loading shader "system/shaders/sun_flare_mark.glsl"
    [MT] ERROR: Compiling shader "system/shaders/sun_flare_mark.glsl":
    ERROR: 0:1: '' : Version number not supported by OGL driver
    ERROR: 0:1: '' : syntax error #version
    ERROR: 0:6: 'mat4x4' : syntax error parse error
    [MT] ERROR: Compiling shader "system/shaders/sun_flare_mark.glsl":
    ERROR: 0:1: '' : Version number not supported by OGL driver
    ERROR: 0:1: '' : syntax error #version
    ERROR: 0:6: 'mat4x4' : syntax error parse error
    [MT] ERROR: Linking shader "system/shaders/sun_flare_mark.glsl":

    [MT] Loading shader "system/shaders/sun_flare_conv.glsl"
    [MT] ERROR: Compiling shader "system/shaders/sun_flare_conv.glsl":
    ERROR: 0:1: '' : Version number not supported by OGL driver
    ERROR: 0:1: '' : syntax error #version
    ERROR: 0:13: 'layout' : syntax error parse error
    [MT] ERROR: Compiling shader "system/shaders/sun_flare_conv.glsl":
    ERROR: 0:1: '' : Version number not supported by OGL driver
    ERROR: 0:1: '' : syntax error #version
    ERROR: 0:25: 'in' : supported in GLSL 1.30 or later
    ERROR: 0:26: 'layout' : syntax error parse error
    [MT] ERROR: Linking shader "system/shaders/sun_flare_conv.glsl":

    [MT] Loading shader "system/shaders/sun_flare_ghost.glsl"
    [MT] ERROR: Compiling shader "system/shaders/sun_flare_ghost.glsl":
    ERROR: 0:1: '' : Version number not supported by OGL driver
    ERROR: 0:1: '' : syntax error #version
    ERROR: 0:5: 'mat4x4' : syntax error parse error
    [MT] ERROR: Compiling shader "system/shaders/sun_flare_ghost.glsl":
    ERROR: 0:1: '' : Version number not supported by OGL driver
    ERROR: 0:1: '' : syntax error #version
    ERROR: 0:5: 'mat4x4' : syntax error parse error
    [MT] ERROR: Linking shader "system/shaders/sun_flare_ghost.glsl":

    [MT] Loading shader "system/shaders/sun_flare_ghost_read.glsl"
    [MT] ERROR: Compiling shader "system/shaders/sun_flare_ghost_read.glsl":
    ERROR: 0:1: '' : Version number not supported by OGL driver
    ERROR: 0:1: '' : syntax error #version
    ERROR: 0:6: 'mat4x4' : syntax error parse error
    [MT] ERROR: Compiling shader "system/shaders/sun_flare_ghost_read.glsl":
    ERROR: 0:1: '' : Version number not supported by OGL driver
    ERROR: 0:1: '' : syntax error #version
    ERROR: 0:6: 'mat4x4' : syntax error parse error
    [MT] ERROR: Linking shader "system/shaders/sun_flare_ghost_read.glsl":

    [MT] Loading shader "system/shaders/billboard.glsl"
    [MT] ERROR: Compiling shader "system/shaders/billboard.glsl":
    ERROR: 0:1: '' : Version number not supported by OGL driver
    ERROR: 0:1: '' : syntax error #version
    ERROR: 0:5: 'mat4x4' : syntax error parse error
    [MT] ERROR: Compiling shader "system/shaders/billboard.glsl":
    ERROR: 0:1: '' : Version number not supported by OGL driver
    ERROR: 0:1: '' : syntax error #version
    ERROR: 0:5: 'mat4x4' : syntax error parse error
    [MT] ERROR: Linking shader "system/shaders/billboard.glsl":

    plz guys help me and sorry for my realy bad eng
     
    MosfetDate: Monday, 15.02.2016, 20:08 | Message # 416
    World Builder
    Group: Users
    Italy
    Messages: 754
    Status: Offline
    hi opsee_moo5, those errors could have been caused by old or faulty drivers of your graphic card.
    Try with updated drivers, check your graphic card manufacturer.
    If you speak French or you are more comfortable with French, there's a brand new Section Française.





    "Time is illusion. Lunchtime doubly so."
    Douglas N. Adams
    My mods
    Asus x555ub: cpu i5-6200u - ram 4gb - gpu nvidia geforce 940m 2gb vram
     
    schrodingers_catDate: Saturday, 20.02.2016, 19:27 | Message # 417
    Observer
    Group: Newbies
    United States
    Messages: 4
    Status: Offline
    Can't enable V-Sync.

    While I can change the setting it has no affect in any full or window screen mode. The vertical tearing is horrendous. I tried forcing it through Nvidia control panel but that didn't help

    happens on 9.7.2, 9.7.3, and the latest 9.7.4. My drivers are up-to-date.

    OS:Win 10
    CPU: Intell 4790k
    GPU: Nvidia 970 gtx
     
    DoctorOfSpaceDate: Saturday, 20.02.2016, 21:34 | Message # 418
    Galaxy Architect
    Group: Global Moderators
    Pirate
    Messages: 3600
    Status: Offline
    schrodingers_cat, try changing it in the Main.cfg file.

    The only method that worked for me was setting it to this

    Code
    VSync                   1  // vertical synchronization (0 - disabled, 1 - enabled, 2 - auto)





    Intel Core i7-5820K 4.2GHz 6-Core Processor
    G.Skill Ripjaws V Series 32GB (4 x 8GB) DDR4-2400 Memory
    EVGA GTX 980 Ti SC 6GB
     
    schrodingers_catDate: Sunday, 21.02.2016, 00:04 | Message # 419
    Observer
    Group: Newbies
    United States
    Messages: 4
    Status: Offline
    Quote DoctorOfSpace ()
    The only method that worked for me was setting it to this


    I get the same regardless of mode

    Added (21.02.2016, 00:04)
    ---------------------------------------------

    Quote schrodingers_cat ()
    Can't enable V-Sync.

    While I can change the setting it has no affect in any full or window screen mode. The vertical tearing is horrendous. I tried forcing it through Nvidia control panel but that didn't help

    happens on 9.7.2, 9.7.3, and the latest 9.7.4. My drivers are up-to-date.

    OS:Win 10
    CPU: Intell 4790k
    GPU: Nvidia 970 gtx


    Found solution. Disable high DPI scaling. I'm playing on a 4k monitor
     
    cah9tlanDate: Friday, 26.02.2016, 12:09 | Message # 420
    Observer
    Group: Users
    Pirate
    Messages: 17
    Status: Offline
    Hi,
    I cannot even have my first run through space. Fails on exe:"The procedure entry point EnumSystemLocalesEx could not be located in the dynamic link library KERNEL32.dll". Win XP(SP3) x86, ATI Radeon 4800

    Dear SpaceEngine, Please, address this problem, cause it's pretty frequent (or just say it's incurable and you won't fix it - to exclude my vain hopes cry smile ):
    Quote
    cmep4d
    Дата: Воскресенье, 19.04.2015, 14:17 | Сообщение # 14
    Нет аватара
    Наблюдатель
    Группа: Новички
    Пират
    Сообщений: 3
    Награды: 0 +
    Репутация: 0 ±
    Замечания: 0%
    Статус: Offline
    Так и осталась проблема с XP, "Точка входа в процедуру EnumSystemLocalesEx не найдена в библиотеке DLL KERNEL32.dll". (Win XP(SP3) x86, ATI Radeon 4800, 4G RAM)
    Прикрепления: 5365067.jpg(12Kb) · 5631731.log(0Kb)


    Quote
    37 Raj (19.08.2015 08:24)
    Hi Space Engineer, I get the below error message,

    The procedure entry point EnumSystemLocalesEx could not be located in the dynamic link library KERNEL32.dll.

    I waited for this bug to be fixed in 0.9.7.3 but it doesn't seem to work. Please help me fix it, I like this program a lot smile


    Quote
    bzzommbo Date: Saturday, 13.02.2016, 15:58 | Message # 407
    Observer
    Group: Users
    Pirate
    Messages: 13
    Status: Offline
    EnumSystemLocalesEx wasn't fund in KERNEL32.dll library.
    Previously, it was InitializeCriticalSectionEx, now it's EnumSystemLocalesEx.
    I kinda know coding - when you fix one thing, 10 more errors are made.

    Added (26.02.2016, 12:09)
    ---------------------------------------------
    Thank you very much for knocking yourselves out to help me, but problem is already solved.

     
    Forum » SpaceEngine » Archive » Troubleshooting and bug reports - SpaceEngine 0.9.7.3
    Search: