ENG New site

Advanced search

[ New messages · Forum rules · Members ]
Forum » SpaceEngine » Archive » Troubleshooting and bug reports - SpaceEngine
Troubleshooting and bug reports - SpaceEngine
SpaceEngineerDate: Thursday, 26.12.2013, 00:29 | Message # 1
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4800
Status: Offline
Please post here all of your reports about bugs or crashes in SpaceEngine. Before you post any bugs, please follow these steps:

  • Read the Fixing common issues section below. It is possible that your problem can be solved there.
  • Read the List of known issues section below and make sure that your bugs are not on in it. You can use your browser's word finder to help search the list.
  • If the bug is not on the list then please post it in this thread. Attach to your message a screenshot (if possible) and a log file (it's called the se.log and is located in the SpaceEngine/system/ directory). Only the log file will help me to understand your problem and find a solution!

    Fixing common issues

    1) Obsolete or incompatible drivers
    These are the most frequent errors found in SE. You will get a popup window with one of these following messages:

    - "You have old OpenGL version (2.1.1). Update your graphics card driver or install compatible hardware"

    - "You have old GLSL version (1.2). Update your graphics card driver or install compatible hardware"

    - "Critical extensions missing: GL_ARB_vertex_program GL_ARB_vertex_buffer_object"

    - "Error loading surface generator shaders. Press YES to run program with procedural planets disabled. Press NO to exit"

    Download and install latest drivers for your video card. If you still get this message, it could be that you have an incompatible video card (see next paragraph).

    [CRITICAL NOTE] Some recent NVidia drivers are incompatible with SE. Symptoms are flashing planet images on the screen when you open the F2 menu (see the spoiler), missing lens flares, grayed out options for HDR and FXAA in the Graphics settings menu, and other glitches. The errors in the se.log are look like this:

    If you have run into these problems, update to at least 344.65, or roll back to earlier than 337.xx.

    But you still can try and run SpaceEngine by disabling checking of critical errors at startup. Open main.cfg and change value of this parameter to 'true':

    IgnoreCriticalCheck true // ignore checking of OpenGL version and critical extensions supporting

    NOTE: I can give no guaranties that SpaceEngine will be stable and work correctly if you do make this change.

    If you have an "Error loading surface generator shaders" error and press Yes, SpaceEngine can run, but it will not be able to render procedural planetary landscapes.

    After updating or rollback of the drivers, you must delete the cache folder in the SpaceEngine directory.

    2) Weak system
    Most of the forum posts I receive are from users that report an inability to start SpaceEngine, This is because those users have inbuilt Intel graphics card, or some old GeForce 5700 series, or not a proper "gaming" laptop. There is no way but to update your hardware system. There are no plans to make a second version of the engine for weaker systems with simplified graphics, CPU texture generation, etc. It would be like coding another engine from scratch. Once again, I would remind everyone that the minimum system requirements can be found on the Home page, but I will mention it here as well:

    CPU 2.0 GHz
    RAM 2 Gb
    Video GeForce 8600, Radeon HD 2600
    vRAM 512 Mb

    I stress that the special role played by videocard onboard memory (vRAM). 512 MB is the absolute minimum. The engine uses a large amount of data that must be in video memory (textures, meshes, vbo, etc). If your system meets the recommended requirements, the engine will work, because its development is made for this hardware:

    CPU 3.0 GHz
    RAM 4 Gb
    Video GeForce 9800 GTX, ATI Mobility HD 5730
    vRAM 1024 Mb

    You can try to start the engine with some OpenGL extensions disabed, if your hardware does not support them: frame buffer objects (FBO), half floats, float textures and 3D textures. Information about this is written at the beginning of the log (SpaceEngine/system/se.log), after the list of extensions:

    Framebuffer objects supported
    Half floats suppoted
    Floating-point pixel format: GL_RGBA16F_ARB
    3D textures suppoted

    If the log reads 'unsupported, then the extension is not supported and the engine will disable itself. If it seems to support float and 3D textures, but the atmosphere of planets has some monstrous bottleneck, such as the GeForce 6200 and GeForce 6600, then it is best to disable those extensions forcibly. This is done in the file config/main.cfg:

    IgnoreFBO false // disable framebuffer objects
    IgnoreHalfFloat false // disable half floats
    IgnoreFloatTextures false // disable float textures
    Ignore3DTextures false // disable 3D textures
    IgnoreShaderBinary false // disable binary shaders cache
    IgnoreCriticalCheck false // ignore checking of OpenGL version and critical extensions supporting

    - The Milky Way and other nearby galaxies and nebulae use FBO. HDR rendering mode also use FBO. Disabling it disables the 3D models of galaxies and nebulae, and disables HDR mode.
    - Atmospheres using float and 3D textures. Disabling any of them disables the atmosphere. HDR rendering mode uses a float textures, disabling them disables HDR.
    - Shader binary cache reduces lags on loading shaders. Works normally on NVidia, onr ATI and Intel it disabled automatically after first laubch of SpaceEngine.

    If you have a Intel HD graphics card, it is better to disable asynchronous loading in the main.cfg as well:

    LoaderMode 2 // loader mode: 0 = immediate, 1 = interleaved, 2 = asynchronous

    3) System with hybrid graphics (NVidia/ATI + Intel HD)
    If you're running SE on a laptop with dual graphics, make sure SE runs on NVidia or ATI chip instead of Intel HD. You may see it in the beginning of "SpaceEngine/system/se.log" file. If it says:

    Vendor: Intel
    Renderer: Intel® HD Graphics 4000

    then you should open NVidia Control Panel or ATI Catalyst and force SpaceEngine.exe run on NVidia/ATI graphics card. If you do not found SpaceEngine profile there, create a new one.

    4) Crashing in the interstellar or intergalactic space or after appearing of the nebula in the view field
    If you open the "SpaceEngine/system/se.log" file after a crash, and it ends up with line like this:

    Creating nebula model "cache/models/nebulae/M42.nm",

    then try to disable asynchronous loading of a resources. Open the file config/main.cfg with the Notepad and change this parameter to 1:

    LoaderMode 1 // loader mode: 0 = immediate, 1 = interleaved, 2 = asynchronous

    After that, delete the cache folder from the SpaceEngine directory. Performance will drop while flying between a stars and galaxies, but stability may be improved. After a while, all models of galaxies and nebulae a being be generated, and you may enable asynchronous loading back (set up LoaderMode 2).

    5) Spaceship disappear when far from a star
    It is not a bug. Current version have not yet completed spaceships rendering system - they cannot be rendered if there is no stars or planets in the renderlist. Just imagine that ship becomes invisible in interstellar flight smile

    6) Blurry textures on Solar system planets
    It is not a bug. Our Solar system planets (Mercury, Venus, Earth, Moon, Mars, Jupiter, Saturn, Uranus, Neptune and its satellites) have no procedural textures, only real ones with limited level-of-detail. You can download addons with high resolution textures to increase level of detail of real planets.

    7) Artifacts on procedural planets
    If you get missing landscape blocks, blurry or blinking textures, random spikes sticking out of surface, check out these recommendations here:

    a) If you have a laptop with hybrid graphics, read the paragraph 3.

    b) Make sure that you make a "clean" installation of SE. If you install a new version overwriting the old one, you may get many bugs and glitches. If you get some glitches after the patch is installed, remove the folder called cache from SpaceEngine's directory.

    c) If this does not help, read the paragraph 8.

    8) Frequent crashing while generating planetary surface
    If you have frequent crashes on planets, or get an "OUT OF MEMORY" message on screen, or "Unexpected deleting of child node" in the log file, try taking these steps first:

  • Close any other programs that can consume the video memory (games, video players, graphics editors, etc.). SpaceEngine is not a small flash type game, video memory is the most important resource for it. It may help to disable the Windows Aero theme too, as it consumes a lot of video memory.
  • Disable "3D water" in Graphics settings (Ctrl-F4)
  • Reduce "Landscape LOD" to -2 in Graphics settings (Ctrl+F4)
  • Set up the amount of video memory in the main.cfg file:

    VideoMemorySize 2048 // video card onboard memory (VRAM) in megabytes

    The value must not be less than 1024, but not more than the total amount of physical video memory plus amount of RAM. For example, if you have a graphics card with 1024 MB of video memory, and more than 2 GB of RAM, you can increase VideoMemorySize to 2048.

    List of known issues

    Green items have been fixed for the next release

    Not real bugs, but effects caused by limitations in the engine:
    - Ships do not render in interstellar space
    - Star catalog has many errors in star classification, so there are many "giant dwarfs" and "dwarf giants"
    - Many real binary stars rendered as single, and many single rendered as binary - SE simply have incomplete catalog of binary stars
    - An unwanted star (sprite) is visible in the barycenter of a binary star from distance greater than 0.01 pc
    - Comet nucleus star-sprite will shine through planets [example].
    - Galaxy/nebula sprites will rotate when seen from certain angles
    - Auroras, comet tails and rings can be rendered in front of ships/moons sometimes
    - Lens flares are distorted by gravitational lensing (black holes and ship warp drive effect)
    - Text editor for Wiki descriptions is not working - it is not implemented yet
    - Solar system moons don't have extremely accurate orbits (requires implementation of custom orbit models, e.g. VSOP-87)
    - Sunspot distribution is not always realistic
    - Ocean tag not yet implemented in planet editor
    - Rounding errors (e.g. 30° in catalog rounds to 29°59'59.99" displayed on HUD)
    - Ship retro engines have not been implemented yet

    Real bugs:
    - Too many planets with life (panspermia issue)
    - Oceanias have landscapes above water
    - Several bugs with the planet editor
    - Changing "modes" between simulation and orbital when piloting ships can cause glitches
    - Few issues with asynchronous loading (stars don't always generate properly, especially when flying to new galaxies)
    - Holes in some giant stars when camera is directly above a very tall spot [example]
    - Flashing landscape LOD on a planet when Wiki for it is displayed
    - Star clusters not displayed in Wiki
    - GUI response issues with some users (interface items glitchy or not respond easily)
    - GUI toolbars may completely disappear when pressing pin button while half-hidden
    - Deep space objects (e.g. stars, galaxies) will shine through planets when HDR for DSO is off, but HDR is on and Bloom is on [example]
    - Some neutron stars can have very low temperatures [example]
    - Flickering flare color in close binary systems [example]
    - Auto-exposure does not react when a sun is blocked while diffraction spikes are set to normal or super
    - Planet rings have an unrealistic color palette
    - "Eclipse bug" on distant planets (weird dark shimmering on outer planet caused by inner planet crossing the sun or two suns eclipsing)
    - Cloud cyclones have cut edges sometimes
    - Level horizon command (End key) doesn't work properly on oblate objects
    - Problems when releasing Left + Right click
    - Lines or junctures are visible on planetary surface
    - Switching to fullscreen doesn't work sometimes
    - Weird behavior of movement keys in tracking mode (T) and after releasing it
    - Automatic reference object setting with spacecraft doesn't always choose the best object (for example, when near dwarf moons or debris asteroids close to a planet you are trying to orbit)
    - 3D water fog sometimes starts above the water surface
    - Problems with the skybox export interface, and with the planetarium after using it, for some users
    - Music player will unpause when SE window is minimized and restored, or when entering and exiting the main menu
    - If a galaxy model is selected, the camera is not following any object, and the program is in Edit Mode, closing and restarting the program will cause the WASDRF movement keys to behave incorrectly until the camera is set to follow an object
    - "Crop orbits" in the Map mode doesn't work
    - Spaceship and lens flare textures do not load when loader mode is set to "Immediate"
    - Visual atmosphere heights are inconsistently and unrealistically generated
    - Physical atmosphere properties are inconsistently and unrealistically generated, and are not tied to the visual models
    - Dwarf moons can be generated on colliding orbits
    - Moons are never generated with retrograde orbits
    - Bugs with the surfaces of carbon stars and zirconium stars
    - Cyclones are not generated in the southern hemispheres of gas giants
    - Sometimes, worlds which are too small are classed as "selena" when they should be classed as asteroid
    - Shimmering bloom splotch when very close to the surface of a planet [example]
    - CW/CCW rotation keys for ship in atmosphere are reversed
    - Mouse axis inversion settings for spaceship controls are not saved
    - Z faces are switched when exporting skyboxes (pos_Z is really neg_Z)
    armheadfood7Date: Monday, 08.12.2014, 20:42 | Message # 811
    Group: Newbies
    United States
    Messages: 3
    Status: Offline
    Right . . . not sure how I didn't notice that before. Thanks.

    I'm still having the problem, though, where none of the other galaxies are rendering. I'm getting the Milky Way, the Magellanic Clouds, Triangulum, and Andromeda, and nothing else, no matter how far away from the Milky Way I travel.

    EDIT: Okay, it's looking more like the different galaxies only render after I specifically select them and hit "G". From then on, they seem to render more or less regularly. This, for instance, is what I'm getting when I look at Andromeda:

    EDIT EDIT: I also now have a screenshot of what I was describing before with the stars flooding the screen (and also the log, if that proves useful):

    Attachments: 0145617.jpg(23.3 Kb) · 9667403.jpg(126.8 Kb) · 1086146.log(32.9 Kb)

    Edited by armheadfood7 - Monday, 08.12.2014, 20:59
    HarbingerDawnDate: Monday, 08.12.2014, 21:14 | Message # 812
    Cosmic Curator
    Group: Administrators
    United States
    Messages: 8717
    Status: Offline
    For the galaxies, press F7 and make sure auto galaxy magnitude is checked. I have no idea what the issue with the map mode might be.

    All forum users, please read this!
    My SE mods and addons
    Phenom II X6 1090T 3.2 GHz, 16 GB DDR3 RAM, GTX 970 3584 MB VRAM
    armheadfood7Date: Monday, 08.12.2014, 21:47 | Message # 813
    Group: Newbies
    United States
    Messages: 3
    Status: Offline
    That worked (it must have been reset when the weird map crash thing happened). Thanks!

    EDIT: Okay, I figured out how to consistently get the map glitch to happen. It happens whenever I go to R136a1; there's a weird "phantom star" thing (I don't know what else to call it) that appears next to R136a1 in the map view. Clicking on it and then attempting to return to the regular view results in the glitch.

    Attachments: 3686533.jpg(75.0 Kb)

    Edited by armheadfood7 - Monday, 08.12.2014, 23:32
    robin-gDate: Tuesday, 09.12.2014, 17:10 | Message # 814
    Group: Newbies
    Messages: 2
    Status: Offline
    As u can see: https://www.youtube.com/watch?v=4byGOJ-O1D8&feature=youtu.be

    I get all these HD-addons and now it looks like this. I think the surface is great, but the landscape is not.

    Please read the forum rules and this thread's opening post. Solar system planets do not have high definition or procedural terrain, so what you're experiencing is normal.

    Added (09.12.2014, 16:10)

    Quote robin-g ()
    Please read the forum rules and this thread's opening post. Solar system planets do not have high definition or procedural terrain, so what you're experiencing is normal.

    Before I had the addons, I saw lakes, mountains and all that stuff.
    For what did I get the landscape earth-HD Addon then, if it looks still like this ?

    | I7-2600k 4.5GHz | 16GB DDR3 1600MHz | GeForce GTX 980 SOC 4GB VRAM |

    Edited by Watsisname - Tuesday, 09.12.2014, 11:21
    HarbingerDawnDate: Tuesday, 09.12.2014, 17:37 | Message # 815
    Cosmic Curator
    Group: Administrators
    United States
    Messages: 8717
    Status: Offline
    It would be helpful if you went to some place that had significant topography, like a mountain range, not eastern North America.

    All forum users, please read this!
    My SE mods and addons
    Phenom II X6 1090T 3.2 GHz, 16 GB DDR3 RAM, GTX 970 3584 MB VRAM
    robin-gDate: Wednesday, 10.12.2014, 22:10 | Message # 816
    Group: Newbies
    Messages: 2
    Status: Offline

    Is that how it has to look ? If then, it's okay.

    But I just noticed another bug.


    | I7-2600k 4.5GHz | 16GB DDR3 1600MHz | GeForce GTX 980 SOC 4GB VRAM |

    Edited by robin-g - Wednesday, 10.12.2014, 22:11
    HarbingerDawnDate: Wednesday, 10.12.2014, 23:39 | Message # 817
    Cosmic Curator
    Group: Administrators
    United States
    Messages: 8717
    Status: Offline
    Yes, that landscape looks fine.

    As for the bug, it's caused by using certain diffraction spike models with "super" mode. You should switch to normal mode, as it is more visually consistent and works better.

    All forum users, please read this!
    My SE mods and addons
    Phenom II X6 1090T 3.2 GHz, 16 GB DDR3 RAM, GTX 970 3584 MB VRAM
    OdinZDate: Friday, 12.12.2014, 16:54 | Message # 818
    Group: Newbies
    Messages: 1
    Status: Offline
    Hi I would like to report a bug with the latest amd drivers.
    Basically all terra planets are made out of only water. Land, mountains, rivers etc. are not rendering.
    I tested display drivers v. 14.3 and v 14.5 (latest) and they don't work, earlier versions however work just fine, my graphics card is an HD 5770.
    FastFourierTransformDate: Friday, 12.12.2014, 22:53 | Message # 819
    Group: Local Moderators
    Messages: 542
    Status: Offline
    I think I've found a "Not real bug, but effect caused by limitations in the engine".

    The clouds on planets and moons get darkened when they enter the night side of the object, as normally should do.
    But the problem is that when an eclipse occurs and the shadow traverses the planet/moon the clouds inside the shadow don't get darker as on the night side. Instead they continue to be totally illuminated with the terrain under them been swallowed by darkness.

    For example this Terra is a moon of an Oceania that makes a "lunar eclipse" on the first. This are different moments of that eclipse:

    Maybe its just as simple as allowing the cloud layer to be shadowed by the planets.
    blackmetalissokawaiiDate: Friday, 12.12.2014, 22:55 | Message # 820
    Group: Newbies
    Messages: 1
    Status: Offline
    I've encountered a problem where when I get close to a binary star or planet (it doesn't seam to effect solitary stars) inside a planetary nebula (It doesn't seam to happen in other kinds of nebula or outside nebulas) the object disappears.
    It is still selected and can still block your movement if you fly into it but its visual representation vanishes so you can see the stuff behind it.
    It seams to happen just a the point the object would turn from a point of light to a 3D model.
    Sometimes I can get it to reappear by looking from certain angles (with planets it seams they reappear if I look straight at the lit up side but disappear if I go towards the dark side at all, with stars the angles seam to be random as far as I can tell)
    I've tried changing all kinds of graphics settings but nothing seams to help. I've also searched this forum but cant seam to find anything similar.

    my PC is:

    Processor: Intel core ig-3570k CPU 3.40GHz
    Operating system: windows 7 64bit
    ram: 16GB
    Graphics card: AMD Radeon HD 6800

    Any help would be appreciated, if you need more info just ask. smile
    leoankh7Date: Tuesday, 16.12.2014, 22:22 | Message # 821
    Group: Newbies
    Messages: 1
    Status: Offline
    hello, I downloaded the Space Engine but it does not work, whenever I open it a message appears saying "3D Space simulator has stopped working".
    I wonder if there is a solution to this problem?

    [My computer:
    Windows 8.1 pro (32 Bits)
    Processador: Pentium ® Dual-Core CPU E5200 @2.5GHz
    RAM: 2048
    DirectX 11
    Intel® 82945G Express Chipset Family
    Video: 256MB]

    SpaceEngine Version beta

    Loading script "config/main.cfg"
    Loading script "config/universe.cfg"
    Loading script "config/user.cfg"
    Loading image "textures/common/splash06.jpg"



    Edited by leoankh7 - Tuesday, 16.12.2014, 22:35
    anonymousgamerDate: Wednesday, 17.12.2014, 00:14 | Message # 822
    World Builder
    Group: Global Moderators
    United States
    Messages: 1011
    Status: Offline
    Quote leoankh7 ()
    hello, I downloaded the Space Engine but it does not work, whenever I open it a message appears saying "3D Space simulator has stopped working".
    I wonder if there is a solution to this problem?

    leoankh7, the answer to your question is in the opening post. Your system's GPU is simply too weak. SE works fine on Windows 8.

    Desktop: FX-8350 4.0 GHz, 8 GB DDR3 RAM, EVGA GeForce GTX 1080 FTW 8 GB, 2 TB HDD, 24 inch 1920x1080 screen
    Laptop: Core i5 480M 2.66 GHz (turbo 2.93), 8 GB DDR3 RAM, AMD Radeon HD 6550m 1 GB, 640 GB HDD, 17.3 inch 1600x900 screen
    FrostynkDate: Thursday, 18.12.2014, 20:37 | Message # 823
    Group: Newbies
    Messages: 1
    Status: Offline
    I want to play Space Engine in my new Oculus Rift DK2, but nowhere puts how I can play it, help.
    TrulskijDate: Thursday, 18.12.2014, 21:06 | Message # 824
    Space Tourist
    Group: Users
    Messages: 28
    Status: Offline
    actual version doesnt support it anyway ^^ 0.971 came long before rift dk2 ^^

    Edited by Trulskij - Thursday, 18.12.2014, 21:07
    MosfetDate: Thursday, 18.12.2014, 21:09 | Message # 825
    World Builder
    Group: Users
    Messages: 754
    Status: Offline
    Searching the forums gives you plenty of infos about it. SpaceEngineer is testing the DK1 it has with the upcoming release of SE, so at the moment only few beta testers If I've understood correctly have prereleases to help ironing the details. If I remember correctly it should be compatible with DK2. http://en.spaceengine.org/forum/11-1124-1
    So, no, you can't yet use it whit current SE version. Be patient and follow this thread: http://en.spaceengine.org/forum/21-2070-1

    "Time is illusion. Lunchtime doubly so."
    Douglas N. Adams
    My mods
    Asus x555ub: cpu i5-6200u - ram 4gb - gpu nvidia geforce 940m 2gb vram

    Edited by Mosfet - Thursday, 18.12.2014, 21:10
    Forum » SpaceEngine » Archive » Troubleshooting and bug reports - SpaceEngine