ENG New site

Advanced search

[ New messages · Forum rules · Members ]
Forum » SpaceEngine » Archive » Troubleshooting and bug reports - SpaceEngine
Troubleshooting and bug reports - SpaceEngine
SpaceEngineerDate: Thursday, 26.12.2013, 00:29 | Message # 1
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4800
Status: Offline
Please post here all of your reports about bugs or crashes in SpaceEngine. Before you post any bugs, please follow these steps:

  • Read the Fixing common issues section below. It is possible that your problem can be solved there.
  • Read the List of known issues section below and make sure that your bugs are not on in it. You can use your browser's word finder to help search the list.
  • If the bug is not on the list then please post it in this thread. Attach to your message a screenshot (if possible) and a log file (it's called the se.log and is located in the SpaceEngine/system/ directory). Only the log file will help me to understand your problem and find a solution!

    Fixing common issues

    1) Obsolete or incompatible drivers
    These are the most frequent errors found in SE. You will get a popup window with one of these following messages:

    - "You have old OpenGL version (2.1.1). Update your graphics card driver or install compatible hardware"

    - "You have old GLSL version (1.2). Update your graphics card driver or install compatible hardware"

    - "Critical extensions missing: GL_ARB_vertex_program GL_ARB_vertex_buffer_object"

    - "Error loading surface generator shaders. Press YES to run program with procedural planets disabled. Press NO to exit"

    Download and install latest drivers for your video card. If you still get this message, it could be that you have an incompatible video card (see next paragraph).

    [CRITICAL NOTE] Some recent NVidia drivers are incompatible with SE. Symptoms are flashing planet images on the screen when you open the F2 menu (see the spoiler), missing lens flares, grayed out options for HDR and FXAA in the Graphics settings menu, and other glitches. The errors in the se.log are look like this:

    If you have run into these problems, update to at least 344.65, or roll back to earlier than 337.xx.

    But you still can try and run SpaceEngine by disabling checking of critical errors at startup. Open main.cfg and change value of this parameter to 'true':

    IgnoreCriticalCheck true // ignore checking of OpenGL version and critical extensions supporting

    NOTE: I can give no guaranties that SpaceEngine will be stable and work correctly if you do make this change.

    If you have an "Error loading surface generator shaders" error and press Yes, SpaceEngine can run, but it will not be able to render procedural planetary landscapes.

    After updating or rollback of the drivers, you must delete the cache folder in the SpaceEngine directory.

    2) Weak system
    Most of the forum posts I receive are from users that report an inability to start SpaceEngine, This is because those users have inbuilt Intel graphics card, or some old GeForce 5700 series, or not a proper "gaming" laptop. There is no way but to update your hardware system. There are no plans to make a second version of the engine for weaker systems with simplified graphics, CPU texture generation, etc. It would be like coding another engine from scratch. Once again, I would remind everyone that the minimum system requirements can be found on the Home page, but I will mention it here as well:

    CPU 2.0 GHz
    RAM 2 Gb
    Video GeForce 8600, Radeon HD 2600
    vRAM 512 Mb

    I stress that the special role played by videocard onboard memory (vRAM). 512 MB is the absolute minimum. The engine uses a large amount of data that must be in video memory (textures, meshes, vbo, etc). If your system meets the recommended requirements, the engine will work, because its development is made for this hardware:

    CPU 3.0 GHz
    RAM 4 Gb
    Video GeForce 9800 GTX, ATI Mobility HD 5730
    vRAM 1024 Mb

    You can try to start the engine with some OpenGL extensions disabed, if your hardware does not support them: frame buffer objects (FBO), half floats, float textures and 3D textures. Information about this is written at the beginning of the log (SpaceEngine/system/se.log), after the list of extensions:

    Framebuffer objects supported
    Half floats suppoted
    Floating-point pixel format: GL_RGBA16F_ARB
    3D textures suppoted

    If the log reads 'unsupported, then the extension is not supported and the engine will disable itself. If it seems to support float and 3D textures, but the atmosphere of planets has some monstrous bottleneck, such as the GeForce 6200 and GeForce 6600, then it is best to disable those extensions forcibly. This is done in the file config/main.cfg:

    IgnoreFBO false // disable framebuffer objects
    IgnoreHalfFloat false // disable half floats
    IgnoreFloatTextures false // disable float textures
    Ignore3DTextures false // disable 3D textures
    IgnoreShaderBinary false // disable binary shaders cache
    IgnoreCriticalCheck false // ignore checking of OpenGL version and critical extensions supporting

    - The Milky Way and other nearby galaxies and nebulae use FBO. HDR rendering mode also use FBO. Disabling it disables the 3D models of galaxies and nebulae, and disables HDR mode.
    - Atmospheres using float and 3D textures. Disabling any of them disables the atmosphere. HDR rendering mode uses a float textures, disabling them disables HDR.
    - Shader binary cache reduces lags on loading shaders. Works normally on NVidia, onr ATI and Intel it disabled automatically after first laubch of SpaceEngine.

    If you have a Intel HD graphics card, it is better to disable asynchronous loading in the main.cfg as well:

    LoaderMode 2 // loader mode: 0 = immediate, 1 = interleaved, 2 = asynchronous

    3) System with hybrid graphics (NVidia/ATI + Intel HD)
    If you're running SE on a laptop with dual graphics, make sure SE runs on NVidia or ATI chip instead of Intel HD. You may see it in the beginning of "SpaceEngine/system/se.log" file. If it says:

    Vendor: Intel
    Renderer: Intel® HD Graphics 4000

    then you should open NVidia Control Panel or ATI Catalyst and force SpaceEngine.exe run on NVidia/ATI graphics card. If you do not found SpaceEngine profile there, create a new one.

    4) Crashing in the interstellar or intergalactic space or after appearing of the nebula in the view field
    If you open the "SpaceEngine/system/se.log" file after a crash, and it ends up with line like this:

    Creating nebula model "cache/models/nebulae/M42.nm",

    then try to disable asynchronous loading of a resources. Open the file config/main.cfg with the Notepad and change this parameter to 1:

    LoaderMode 1 // loader mode: 0 = immediate, 1 = interleaved, 2 = asynchronous

    After that, delete the cache folder from the SpaceEngine directory. Performance will drop while flying between a stars and galaxies, but stability may be improved. After a while, all models of galaxies and nebulae a being be generated, and you may enable asynchronous loading back (set up LoaderMode 2).

    5) Spaceship disappear when far from a star
    It is not a bug. Current version have not yet completed spaceships rendering system - they cannot be rendered if there is no stars or planets in the renderlist. Just imagine that ship becomes invisible in interstellar flight smile

    6) Blurry textures on Solar system planets
    It is not a bug. Our Solar system planets (Mercury, Venus, Earth, Moon, Mars, Jupiter, Saturn, Uranus, Neptune and its satellites) have no procedural textures, only real ones with limited level-of-detail. You can download addons with high resolution textures to increase level of detail of real planets.

    7) Artifacts on procedural planets
    If you get missing landscape blocks, blurry or blinking textures, random spikes sticking out of surface, check out these recommendations here:

    a) If you have a laptop with hybrid graphics, read the paragraph 3.

    b) Make sure that you make a "clean" installation of SE. If you install a new version overwriting the old one, you may get many bugs and glitches. If you get some glitches after the patch is installed, remove the folder called cache from SpaceEngine's directory.

    c) If this does not help, read the paragraph 8.

    8) Frequent crashing while generating planetary surface
    If you have frequent crashes on planets, or get an "OUT OF MEMORY" message on screen, or "Unexpected deleting of child node" in the log file, try taking these steps first:

  • Close any other programs that can consume the video memory (games, video players, graphics editors, etc.). SpaceEngine is not a small flash type game, video memory is the most important resource for it. It may help to disable the Windows Aero theme too, as it consumes a lot of video memory.
  • Disable "3D water" in Graphics settings (Ctrl-F4)
  • Reduce "Landscape LOD" to -2 in Graphics settings (Ctrl+F4)
  • Set up the amount of video memory in the main.cfg file:

    VideoMemorySize 2048 // video card onboard memory (VRAM) in megabytes

    The value must not be less than 1024, but not more than the total amount of physical video memory plus amount of RAM. For example, if you have a graphics card with 1024 MB of video memory, and more than 2 GB of RAM, you can increase VideoMemorySize to 2048.

    List of known issues

    Green items have been fixed for the next release

    Not real bugs, but effects caused by limitations in the engine:
    - Ships do not render in interstellar space
    - Star catalog has many errors in star classification, so there are many "giant dwarfs" and "dwarf giants"
    - Many real binary stars rendered as single, and many single rendered as binary - SE simply have incomplete catalog of binary stars
    - An unwanted star (sprite) is visible in the barycenter of a binary star from distance greater than 0.01 pc
    - Comet nucleus star-sprite will shine through planets [example].
    - Galaxy/nebula sprites will rotate when seen from certain angles
    - Auroras, comet tails and rings can be rendered in front of ships/moons sometimes
    - Lens flares are distorted by gravitational lensing (black holes and ship warp drive effect)
    - Text editor for Wiki descriptions is not working - it is not implemented yet
    - Solar system moons don't have extremely accurate orbits (requires implementation of custom orbit models, e.g. VSOP-87)
    - Sunspot distribution is not always realistic
    - Ocean tag not yet implemented in planet editor
    - Rounding errors (e.g. 30° in catalog rounds to 29°59'59.99" displayed on HUD)
    - Ship retro engines have not been implemented yet

    Real bugs:
    - Too many planets with life (panspermia issue)
    - Oceanias have landscapes above water
    - Several bugs with the planet editor
    - Changing "modes" between simulation and orbital when piloting ships can cause glitches
    - Few issues with asynchronous loading (stars don't always generate properly, especially when flying to new galaxies)
    - Holes in some giant stars when camera is directly above a very tall spot [example]
    - Flashing landscape LOD on a planet when Wiki for it is displayed
    - Star clusters not displayed in Wiki
    - GUI response issues with some users (interface items glitchy or not respond easily)
    - GUI toolbars may completely disappear when pressing pin button while half-hidden
    - Deep space objects (e.g. stars, galaxies) will shine through planets when HDR for DSO is off, but HDR is on and Bloom is on [example]
    - Some neutron stars can have very low temperatures [example]
    - Flickering flare color in close binary systems [example]
    - Auto-exposure does not react when a sun is blocked while diffraction spikes are set to normal or super
    - Planet rings have an unrealistic color palette
    - "Eclipse bug" on distant planets (weird dark shimmering on outer planet caused by inner planet crossing the sun or two suns eclipsing)
    - Cloud cyclones have cut edges sometimes
    - Level horizon command (End key) doesn't work properly on oblate objects
    - Problems when releasing Left + Right click
    - Lines or junctures are visible on planetary surface
    - Switching to fullscreen doesn't work sometimes
    - Weird behavior of movement keys in tracking mode (T) and after releasing it
    - Automatic reference object setting with spacecraft doesn't always choose the best object (for example, when near dwarf moons or debris asteroids close to a planet you are trying to orbit)
    - 3D water fog sometimes starts above the water surface
    - Problems with the skybox export interface, and with the planetarium after using it, for some users
    - Music player will unpause when SE window is minimized and restored, or when entering and exiting the main menu
    - If a galaxy model is selected, the camera is not following any object, and the program is in Edit Mode, closing and restarting the program will cause the WASDRF movement keys to behave incorrectly until the camera is set to follow an object
    - "Crop orbits" in the Map mode doesn't work
    - Spaceship and lens flare textures do not load when loader mode is set to "Immediate"
    - Visual atmosphere heights are inconsistently and unrealistically generated
    - Physical atmosphere properties are inconsistently and unrealistically generated, and are not tied to the visual models
    - Dwarf moons can be generated on colliding orbits
    - Moons are never generated with retrograde orbits
    - Bugs with the surfaces of carbon stars and zirconium stars
    - Cyclones are not generated in the southern hemispheres of gas giants
    - Sometimes, worlds which are too small are classed as "selena" when they should be classed as asteroid
    - Shimmering bloom splotch when very close to the surface of a planet [example]
    - CW/CCW rotation keys for ship in atmosphere are reversed
    - Mouse axis inversion settings for spaceship controls are not saved
    - Z faces are switched when exporting skyboxes (pos_Z is really neg_Z)
    AssassinvrxzDate: Thursday, 05.06.2014, 11:34 | Message # 496
    Group: Newbies
    United States
    Messages: 9
    Status: Offline
    Ok. I have read almost all the pages here and haven't seen anything like this, Its more of a peculiarity that I think should be noted.

    I am only going to post one image here, and then will explain whats going on.

    This appears to be a rather interesting quadruple system, and in reality it is. However the game isn't regestering it properly. Its treating this as two separate systems with two independent barycenters(which happen to be in the same place). I have been using this program for weeks and haven't encountered anything of such.

    The two systems in question are: the red on the top and the blue on the bottom (which includes two far orbiting planets)
    and the other system registered separate is the two other stars. Its quite interesting and fun.

    Attachments: 2743832.jpg(129.8 Kb)
    HarbingerDawnDate: Thursday, 05.06.2014, 11:57 | Message # 497
    Cosmic Curator
    Group: Administrators
    United States
    Messages: 8717
    Status: Offline
    It's not a quadruple system. It's two binary systems that got generated on top of each other for some reason. A quadruple system could not have a configuration like that anyway, you would need to have more barycenters.

    All forum users, please read this!
    My SE mods and addons
    Phenom II X6 1090T 3.2 GHz, 16 GB DDR3 RAM, GTX 970 3584 MB VRAM
    AssassinvrxzDate: Thursday, 05.06.2014, 12:01 | Message # 498
    Group: Newbies
    United States
    Messages: 9
    Status: Offline
    Well most certainly not that way. They clip into eachother. Its the fact it generated that I posted here.
    HarbingerDawnDate: Thursday, 05.06.2014, 13:54 | Message # 499
    Cosmic Curator
    Group: Administrators
    United States
    Messages: 8717
    Status: Offline
    Quote Assassinvrxz ()
    Its the fact it generated that I posted here.

    Yeah. Every once in a while someone finds something like this. One time someone found the same exact system generated on top of itself. But generally these things don't happen.

    All forum users, please read this!
    My SE mods and addons
    Phenom II X6 1090T 3.2 GHz, 16 GB DDR3 RAM, GTX 970 3584 MB VRAM
    DocasmanDate: Friday, 13.06.2014, 11:47 | Message # 500
    Group: Users
    Messages: 12
    Status: Offline
    Hello All,

    I'm trying to create a video and yet, after reading everything I can find, I can't shake off the following problems:

    #1: no codecs, only uncompressed video available. This is odd, as I often use this pc for video production and have many codecs installed; I've confirmed that x264, Xvid and a few from ffdshow are registered on the system also as VFW codecs. Is there a place on the .cfg files where I can specify a default codec? Even uncompressed video would be fine but...

    #2: recording seems limited to a file size of 4GB, and only the final frames get saved to file. Considering I'm recording video at 7680x1080, I only get a few seconds (172 frames maximum).

    #3: of those few seconds, some frame sequences are garbled (for example, the bottom half is on top, the top left is on lower right, the colors are offset...) but usually the last few frames are ok. On rare ocasions only the index is mixed-up and all the 172 frames are ok (but virtualdub thinks there are 406 frames). I guess this is because the saving is interrupted.

    I understand this is an unusual format, but the fact that it sometimes works keeps my expectations high.

    I'm running on Win7 pro 64 bit, Intel I7 2600, 16GB ram, GeForce GTX 650.

    From Virtualdub's log:
    [!] AVI: Index not found or damaged -- reconstructing via file scan.
    [!] AVI: Invalid chunk detected at 2056. Enabling aggressive recovery mode.
    [!] AVI: Keyframe flag reconstruction was not specified in open options and
    the video stream is not a known keyframe-only type. Seeking in the video
    stream may be extremely slow.

    SpaceEngine's log shows nothing unusual, except perhaps "Total RAM: 4095 Mb".

    Added (13.06.2014, 10:47)
    As for #1 above, I found that the codec list (should it be a drop down list?) isn't showing properly. If I select the shown item (uncompressed) and use up/down on the keyboard (or mouse wheel), the "configure" and "about" get enabled/disabled, indicating I'm choosing a different codec, and from that I can figure out which one.

    As I prefer working with lossless compression, I'm bound to run into #2 often...

    FastFourierTransformDate: Tuesday, 17.06.2014, 13:13 | Message # 501
    Group: Local Moderators
    Messages: 542
    Status: Offline
    I think someone should try to respond to Docasman, it's quite important. I've also encountered the same problems. Maybe SE should have a formal video recording tool, with varius options to make fluid and spectacular videos with this amazing software.

    Appart from this, I've found an interesting bug. Colliding moons.

    There's a planet on Carina Nebula called RS 8409-1357-8-7184176-122 1 that has three moons. First I've noticed that one of the moons is extremly close to the planet. I've calculated that 160 km closer and it would surpass the Roche Limit creating a ring system. But that's not the bug obviusly because it's sufficiently far away to exist. The bug is because the second closest moon orbits so near to the first that they collide periodically fusing their surfaces toghether. I've seen this before on compact binary systems but no on moons, so I wanted to report this. Also the third moon (in distance) is closer enought to disturb the orbits of the other two moons and making this entire system imposible.

    I made some pics:

    Attachments: 6050957.jpg(492.1 Kb)

    Edited by FastFourierTransform - Tuesday, 17.06.2014, 13:16
    WatsisnameDate: Tuesday, 17.06.2014, 21:25 | Message # 502
    Galaxy Architect
    Group: Global Moderators
    United States
    Messages: 2613
    Status: Offline
    Docasman, your issue seems to pertain to virtualdub, not Space Engine. It is possible someone here may be familiar with the software and can help you, but your best bet is to go to whoever provides support for it directly. Better yet, use SpaceEngine to export the video frames (see below), and VirtualDub to process them. There are a great deal of advantages in using this method rather than using separate video capture software, such as seamlessness despite lag or low framerate.

    FastFourierTransform, and Docasman, SpaceEngine does have its own utility for exporting video frames. Consult the dedicated thread here. You can also view examples of people achieving great results with it in the SpaceEngine videos thread.

    FastFourierTransform, this is a known issue, and is not a bug but rather a limitation of the present state of how moon systems are generated.

    For both of you, I recommend using the forum search feature.

    FastFourierTransformDate: Tuesday, 17.06.2014, 21:44 | Message # 503
    Group: Local Moderators
    Messages: 542
    Status: Offline
    Quote Watsisname ()
    I recommend using the forum search feature.

    Thank you. I used it but I've not found what i was searching (bad search).
    SpaceEngineerDate: Tuesday, 17.06.2014, 22:00 | Message # 504
    Author of Space Engine
    Group: Administrators
    Russian Federation
    Messages: 4800
    Status: Offline
    Docasman, SE can't record files greater than 4 Gb (or 2Gb, I don't remember), because it uses pretty old Windows video capture system. Just choose some compression encoder like DivX.

    FastFourierTransform, you have very weird looking craters. What are your specs? Do you use AMD graphics card?

    DocasmanDate: Wednesday, 18.06.2014, 01:09 | Message # 505
    Group: Users
    Messages: 12
    Status: Offline
    Thanks for your reply, Watsisname, but perhaps I didn't express myself correctly. I was using the utility. Pressing F9 shows a tiny window for codec selection and configuration, and I was expecting a drop-down menu... however clicking the tiny triangle doesn't show any option other than uncompressed video. However, selecting that option and using the mouse wheel (or up/down keyboard keys) enables the configuration button, which means I'm changing codec, and by the configuration window I can find which one is selected.

    SpaceEngineer, thanks for the confirmation. I can get 4 GB worth of video, which is not too bad now that I found the codecs are there. Unfortunately, I'm allergic to compression artifacts (my eyes twitch rather loudly) so I'm stuck with lossless compression... I found x264 does a great job at it, so the 4 GB might be enough for my needs.

    Now I'm trying to tackle the jumping textures and Moiré patterns on Mercury (high resolution surface map add-on). I'll post later about this when I give up.
    HarbingerDawnDate: Wednesday, 18.06.2014, 03:52 | Message # 506
    Cosmic Curator
    Group: Administrators
    United States
    Messages: 8717
    Status: Offline
    Quote Watsisname ()
    SpaceEngine does have its own utility for exporting video frames.

    No, this was replaced with the AVI recorder in the present version. This is what they're having trouble with.

    All forum users, please read this!
    My SE mods and addons
    Phenom II X6 1090T 3.2 GHz, 16 GB DDR3 RAM, GTX 970 3584 MB VRAM

    Edited by HarbingerDawn - Thursday, 19.06.2014, 02:07
    WatsisnameDate: Thursday, 19.06.2014, 01:57 | Message # 507
    Galaxy Architect
    Group: Global Moderators
    United States
    Messages: 2613
    Status: Offline
    Oh, my apologies, guys! I wasn't familiar with the new video recording scheme.

    VoekoevakaDate: Monday, 23.06.2014, 18:52 | Message # 508
    World Builder
    Group: SE team
    Messages: 1016
    Status: Offline
    A quite annoying bug. Since a few days, I've been trying to add a cloud layer to some planets, and I didn't see appearing in the engine. Harb made me notice that the clouds are compressed as a small sphere at the center of the planets, and they are not following the rotation of the planet. I tried to add the the radius ofthe planet on "clouds Height" parameters, but there are still graphical glitches.

    Want some music of mine ? Please go here !

    SpaceEngineerDate: Monday, 23.06.2014, 23:20 | Message # 509
    Author of Space Engine
    Group: Administrators
    Russian Federation
    Messages: 4800
    Status: Offline
    Look how they made for Earth. Did you forget some parameters? Show us the script.

    HarbingerDawnDate: Tuesday, 24.06.2014, 00:29 | Message # 510
    Cosmic Curator
    Group: Administrators
    United States
    Messages: 8717
    Status: Offline
    He is saying that the clouds are added to the planet, but are rendered as a tiny sphere in the center of the planet (like the planet radius is ignored when drawing the cloud layer), like this:

    Default FOV
    Zoomed in

    You have to clip through the terrain, use ambient lighting, and look at the center of the planet to see them. I have only had this problem with Mars. Even when I copy all of the Mars parameters to Earth and test it I still do not have the problem. It is only Mars.

    The bug also exists on a vanilla install with no mods.

    All forum users, please read this!
    My SE mods and addons
    Phenom II X6 1090T 3.2 GHz, 16 GB DDR3 RAM, GTX 970 3584 MB VRAM

    Edited by HarbingerDawn - Tuesday, 24.06.2014, 00:31
    Forum » SpaceEngine » Archive » Troubleshooting and bug reports - SpaceEngine