ENG New site

Advanced search

[ New messages · Forum rules · Members ]
Forum » SpaceEngine » Archive » Troubleshooting and bug reports - SpaceEngine
Troubleshooting and bug reports - SpaceEngine
SpaceEngineerDate: Thursday, 26.12.2013, 00:29 | Message # 1
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4800
Status: Offline
Please post here all of your reports about bugs or crashes in SpaceEngine. Before you post any bugs, please follow these steps:

  • Read the Fixing common issues section below. It is possible that your problem can be solved there.
  • Read the List of known issues section below and make sure that your bugs are not on in it. You can use your browser's word finder to help search the list.
  • If the bug is not on the list then please post it in this thread. Attach to your message a screenshot (if possible) and a log file (it's called the se.log and is located in the SpaceEngine/system/ directory). Only the log file will help me to understand your problem and find a solution!

    Fixing common issues

    1) Obsolete or incompatible drivers
    These are the most frequent errors found in SE. You will get a popup window with one of these following messages:

    - "You have old OpenGL version (2.1.1). Update your graphics card driver or install compatible hardware"

    - "You have old GLSL version (1.2). Update your graphics card driver or install compatible hardware"

    - "Critical extensions missing: GL_ARB_vertex_program GL_ARB_vertex_buffer_object"

    - "Error loading surface generator shaders. Press YES to run program with procedural planets disabled. Press NO to exit"

    Download and install latest drivers for your video card. If you still get this message, it could be that you have an incompatible video card (see next paragraph).

    [CRITICAL NOTE] Some recent NVidia drivers are incompatible with SE. Symptoms are flashing planet images on the screen when you open the F2 menu (see the spoiler), missing lens flares, grayed out options for HDR and FXAA in the Graphics settings menu, and other glitches. The errors in the se.log are look like this:

    If you have run into these problems, update to at least 344.65, or roll back to earlier than 337.xx.

    But you still can try and run SpaceEngine by disabling checking of critical errors at startup. Open main.cfg and change value of this parameter to 'true':

    IgnoreCriticalCheck true // ignore checking of OpenGL version and critical extensions supporting

    NOTE: I can give no guaranties that SpaceEngine will be stable and work correctly if you do make this change.

    If you have an "Error loading surface generator shaders" error and press Yes, SpaceEngine can run, but it will not be able to render procedural planetary landscapes.

    After updating or rollback of the drivers, you must delete the cache folder in the SpaceEngine directory.

    2) Weak system
    Most of the forum posts I receive are from users that report an inability to start SpaceEngine, This is because those users have inbuilt Intel graphics card, or some old GeForce 5700 series, or not a proper "gaming" laptop. There is no way but to update your hardware system. There are no plans to make a second version of the engine for weaker systems with simplified graphics, CPU texture generation, etc. It would be like coding another engine from scratch. Once again, I would remind everyone that the minimum system requirements can be found on the Home page, but I will mention it here as well:

    CPU 2.0 GHz
    RAM 2 Gb
    Video GeForce 8600, Radeon HD 2600
    vRAM 512 Mb

    I stress that the special role played by videocard onboard memory (vRAM). 512 MB is the absolute minimum. The engine uses a large amount of data that must be in video memory (textures, meshes, vbo, etc). If your system meets the recommended requirements, the engine will work, because its development is made for this hardware:

    CPU 3.0 GHz
    RAM 4 Gb
    Video GeForce 9800 GTX, ATI Mobility HD 5730
    vRAM 1024 Mb

    You can try to start the engine with some OpenGL extensions disabed, if your hardware does not support them: frame buffer objects (FBO), half floats, float textures and 3D textures. Information about this is written at the beginning of the log (SpaceEngine/system/se.log), after the list of extensions:

    Framebuffer objects supported
    Half floats suppoted
    Floating-point pixel format: GL_RGBA16F_ARB
    3D textures suppoted

    If the log reads 'unsupported, then the extension is not supported and the engine will disable itself. If it seems to support float and 3D textures, but the atmosphere of planets has some monstrous bottleneck, such as the GeForce 6200 and GeForce 6600, then it is best to disable those extensions forcibly. This is done in the file config/main.cfg:

    IgnoreFBO false // disable framebuffer objects
    IgnoreHalfFloat false // disable half floats
    IgnoreFloatTextures false // disable float textures
    Ignore3DTextures false // disable 3D textures
    IgnoreShaderBinary false // disable binary shaders cache
    IgnoreCriticalCheck false // ignore checking of OpenGL version and critical extensions supporting

    - The Milky Way and other nearby galaxies and nebulae use FBO. HDR rendering mode also use FBO. Disabling it disables the 3D models of galaxies and nebulae, and disables HDR mode.
    - Atmospheres using float and 3D textures. Disabling any of them disables the atmosphere. HDR rendering mode uses a float textures, disabling them disables HDR.
    - Shader binary cache reduces lags on loading shaders. Works normally on NVidia, onr ATI and Intel it disabled automatically after first laubch of SpaceEngine.

    If you have a Intel HD graphics card, it is better to disable asynchronous loading in the main.cfg as well:

    LoaderMode 2 // loader mode: 0 = immediate, 1 = interleaved, 2 = asynchronous

    3) System with hybrid graphics (NVidia/ATI + Intel HD)
    If you're running SE on a laptop with dual graphics, make sure SE runs on NVidia or ATI chip instead of Intel HD. You may see it in the beginning of "SpaceEngine/system/se.log" file. If it says:

    Vendor: Intel
    Renderer: Intel® HD Graphics 4000

    then you should open NVidia Control Panel or ATI Catalyst and force SpaceEngine.exe run on NVidia/ATI graphics card. If you do not found SpaceEngine profile there, create a new one.

    4) Crashing in the interstellar or intergalactic space or after appearing of the nebula in the view field
    If you open the "SpaceEngine/system/se.log" file after a crash, and it ends up with line like this:

    Creating nebula model "cache/models/nebulae/M42.nm",

    then try to disable asynchronous loading of a resources. Open the file config/main.cfg with the Notepad and change this parameter to 1:

    LoaderMode 1 // loader mode: 0 = immediate, 1 = interleaved, 2 = asynchronous

    After that, delete the cache folder from the SpaceEngine directory. Performance will drop while flying between a stars and galaxies, but stability may be improved. After a while, all models of galaxies and nebulae a being be generated, and you may enable asynchronous loading back (set up LoaderMode 2).

    5) Spaceship disappear when far from a star
    It is not a bug. Current version have not yet completed spaceships rendering system - they cannot be rendered if there is no stars or planets in the renderlist. Just imagine that ship becomes invisible in interstellar flight smile

    6) Blurry textures on Solar system planets
    It is not a bug. Our Solar system planets (Mercury, Venus, Earth, Moon, Mars, Jupiter, Saturn, Uranus, Neptune and its satellites) have no procedural textures, only real ones with limited level-of-detail. You can download addons with high resolution textures to increase level of detail of real planets.

    7) Artifacts on procedural planets
    If you get missing landscape blocks, blurry or blinking textures, random spikes sticking out of surface, check out these recommendations here:

    a) If you have a laptop with hybrid graphics, read the paragraph 3.

    b) Make sure that you make a "clean" installation of SE. If you install a new version overwriting the old one, you may get many bugs and glitches. If you get some glitches after the patch is installed, remove the folder called cache from SpaceEngine's directory.

    c) If this does not help, read the paragraph 8.

    8) Frequent crashing while generating planetary surface
    If you have frequent crashes on planets, or get an "OUT OF MEMORY" message on screen, or "Unexpected deleting of child node" in the log file, try taking these steps first:

  • Close any other programs that can consume the video memory (games, video players, graphics editors, etc.). SpaceEngine is not a small flash type game, video memory is the most important resource for it. It may help to disable the Windows Aero theme too, as it consumes a lot of video memory.
  • Disable "3D water" in Graphics settings (Ctrl-F4)
  • Reduce "Landscape LOD" to -2 in Graphics settings (Ctrl+F4)
  • Set up the amount of video memory in the main.cfg file:

    VideoMemorySize 2048 // video card onboard memory (VRAM) in megabytes

    The value must not be less than 1024, but not more than the total amount of physical video memory plus amount of RAM. For example, if you have a graphics card with 1024 MB of video memory, and more than 2 GB of RAM, you can increase VideoMemorySize to 2048.

    List of known issues

    Green items have been fixed for the next release

    Not real bugs, but effects caused by limitations in the engine:
    - Ships do not render in interstellar space
    - Star catalog has many errors in star classification, so there are many "giant dwarfs" and "dwarf giants"
    - Many real binary stars rendered as single, and many single rendered as binary - SE simply have incomplete catalog of binary stars
    - An unwanted star (sprite) is visible in the barycenter of a binary star from distance greater than 0.01 pc
    - Comet nucleus star-sprite will shine through planets [example].
    - Galaxy/nebula sprites will rotate when seen from certain angles
    - Auroras, comet tails and rings can be rendered in front of ships/moons sometimes
    - Lens flares are distorted by gravitational lensing (black holes and ship warp drive effect)
    - Text editor for Wiki descriptions is not working - it is not implemented yet
    - Solar system moons don't have extremely accurate orbits (requires implementation of custom orbit models, e.g. VSOP-87)
    - Sunspot distribution is not always realistic
    - Ocean tag not yet implemented in planet editor
    - Rounding errors (e.g. 30° in catalog rounds to 29°59'59.99" displayed on HUD)
    - Ship retro engines have not been implemented yet

    Real bugs:
    - Too many planets with life (panspermia issue)
    - Oceanias have landscapes above water
    - Several bugs with the planet editor
    - Changing "modes" between simulation and orbital when piloting ships can cause glitches
    - Few issues with asynchronous loading (stars don't always generate properly, especially when flying to new galaxies)
    - Holes in some giant stars when camera is directly above a very tall spot [example]
    - Flashing landscape LOD on a planet when Wiki for it is displayed
    - Star clusters not displayed in Wiki
    - GUI response issues with some users (interface items glitchy or not respond easily)
    - GUI toolbars may completely disappear when pressing pin button while half-hidden
    - Deep space objects (e.g. stars, galaxies) will shine through planets when HDR for DSO is off, but HDR is on and Bloom is on [example]
    - Some neutron stars can have very low temperatures [example]
    - Flickering flare color in close binary systems [example]
    - Auto-exposure does not react when a sun is blocked while diffraction spikes are set to normal or super
    - Planet rings have an unrealistic color palette
    - "Eclipse bug" on distant planets (weird dark shimmering on outer planet caused by inner planet crossing the sun or two suns eclipsing)
    - Cloud cyclones have cut edges sometimes
    - Level horizon command (End key) doesn't work properly on oblate objects
    - Problems when releasing Left + Right click
    - Lines or junctures are visible on planetary surface
    - Switching to fullscreen doesn't work sometimes
    - Weird behavior of movement keys in tracking mode (T) and after releasing it
    - Automatic reference object setting with spacecraft doesn't always choose the best object (for example, when near dwarf moons or debris asteroids close to a planet you are trying to orbit)
    - 3D water fog sometimes starts above the water surface
    - Problems with the skybox export interface, and with the planetarium after using it, for some users
    - Music player will unpause when SE window is minimized and restored, or when entering and exiting the main menu
    - If a galaxy model is selected, the camera is not following any object, and the program is in Edit Mode, closing and restarting the program will cause the WASDRF movement keys to behave incorrectly until the camera is set to follow an object
    - "Crop orbits" in the Map mode doesn't work
    - Spaceship and lens flare textures do not load when loader mode is set to "Immediate"
    - Visual atmosphere heights are inconsistently and unrealistically generated
    - Physical atmosphere properties are inconsistently and unrealistically generated, and are not tied to the visual models
    - Dwarf moons can be generated on colliding orbits
    - Moons are never generated with retrograde orbits
    - Bugs with the surfaces of carbon stars and zirconium stars
    - Cyclones are not generated in the southern hemispheres of gas giants
    - Sometimes, worlds which are too small are classed as "selena" when they should be classed as asteroid
    - Shimmering bloom splotch when very close to the surface of a planet [example]
    - CW/CCW rotation keys for ship in atmosphere are reversed
    - Mouse axis inversion settings for spaceship controls are not saved
    - Z faces are switched when exporting skyboxes (pos_Z is really neg_Z)
    KubeQ11Date: Sunday, 09.02.2014, 22:11 | Message # 301
    Group: Users
    Messages: 12
    Status: Offline
    Quote Voekoevaka ()
    I don't think. But you can test if it happens to you with other localizations.

    It solved the problem. Thanks!

    Added (10.02.2014, 01:11)
    The problem again repeated after 15 minutes of play. I don't know what to do. sad

    PeepBunniesDate: Tuesday, 11.02.2014, 04:21 | Message # 302
    Group: Newbies
    United States
    Messages: 2
    Status: Offline
    I'm not entirely sure this is a bug. I've tried applying the fixes above. Originally I could only keep Space Engine open for a few minutes before it crashed. It's stable now, but I'm having trouble with textures. I've only been able to see the textures of Venus, Jupiter, Saturn, Uranus, and Neptune with atmospheres on. Turned off I can see the Earth and Sun textures. It just shows a black sphere. I have some screenshots of the issue I'm having and I attached the se.log file.

    Atmosphere Off:

    Atmosphere On:

    Computer specs:
    Windows 7 Home Premium 64bit
    Intel i7-2700K 3.5GHz (It's overclocked to 4.60GHz)
    nVidia GeForce GTX 560 x2 (SLI Disabled, PhysX auto-select) driver version: 270.48
    16GB DDR3

    Attachments: 6463283.log(22.5 Kb)

    Edited by PeepBunnies - Tuesday, 11.02.2014, 05:37
    HarbingerDawnDate: Tuesday, 11.02.2014, 12:28 | Message # 303
    Cosmic Curator
    Group: Administrators
    United States
    Messages: 8717
    Status: Offline
    I would say corrupt atmosphere models, but Uranus uses Earth's model, and Pluto uses Jupiter's model, so if that was the case all four objects would be dark.

    I'm not sure what the problem might be, but you can try to change IgnoreShaderBinary to true in the main.cfg file. Then delete the cache folder and start the program. I doubt that's the issue, but it's the only thing I can think to try at the moment.

    Also, your driver version is quite old, you should try to update it (though perhaps not to the latest version, since those have had problems... maybe to something in the 320s)

    All forum users, please read this!
    My SE mods and addons
    Phenom II X6 1090T 3.2 GHz, 16 GB DDR3 RAM, GTX 970 3584 MB VRAM

    Edited by HarbingerDawn - Tuesday, 11.02.2014, 12:31
    KubeQ11Date: Tuesday, 11.02.2014, 12:49 | Message # 304
    Group: Users
    Messages: 12
    Status: Offline
    Hey someone can help me? My problem reapeated and I don't know what to do
    VoekoevakaDate: Tuesday, 11.02.2014, 15:51 | Message # 305
    World Builder
    Group: SE team
    Messages: 1016
    Status: Offline
    Gas Gianlt clound are always too high, and they mask the atmosphere.

    Attachments: 9328922.jpg(87.4 Kb) · 8220528.jpg(106.2 Kb)

    Want some music of mine ? Please go here !

    PeepBunniesDate: Wednesday, 12.02.2014, 08:52 | Message # 306
    Group: Newbies
    United States
    Messages: 2
    Status: Offline
    Quote HarbingerDawn ()
    I'm not sure what the problem might be, but you can try to change IgnoreShaderBinary to true in the main.cfg file. Then delete the cache folder and start the program. I doubt that's the issue, but it's the only thing I can think to try at the moment.

    I'll try this and report back. Thanks =D

    Quote HarbingerDawn ()
    Also, your driver version is quite old, you should try to update it (though perhaps not to the latest version, since those have had problems... maybe to something in the 320s)

    It's my husband's desktop he built himself and he's using the most stable drivers for the cards unfortunately. On my desktop, I've had to keep the original drivers it came with because the new ones were so terrible. Strangely, our gaming laptop displays all the atmosphere models just fine and it's not as powerful as the desktops. =S So weird.
    neutronium76Date: Wednesday, 12.02.2014, 18:23 | Message # 307
    World Builder
    Group: Users
    Messages: 718
    Status: Offline
    After installing latest windows updates, I have seen a dramatic increase in fps and loading times of SE! I am using latest NVidia drivers (332.21) and before today's windows updates I had around 20-30fps around planets at low altitude orbit (sometime less then 20), and now I hardly go below 30! When viewing procedural planet surface from 250-260km orbiting altitude at LOD0, i even get around 50-60fps! and sometimes above that! I also noticed that my gpu is working at full speed now (when running SE), when before it was iddling as if it had entered power saving mode even while running SE!

    I hate to say that but thank you micro$oft...

    PC1:Core i7 [email protected], 6 cores/12 threads, 12GB DDR3 [email protected], 2x(SLI) GTX-580 GPUs 3GB VRAM(GDDR5)@1GHz, OS:Win7x64SP1
    PC2:Core2Quad [email protected], 2 cores/4 threads 4GB DDR2 [email protected], GTX-285 GPU 1GB VRAM(DDR3)@1.24GHz, OS:WinVistax64SP2
    RisingSoulDate: Thursday, 13.02.2014, 02:58 | Message # 308
    Group: Newbies
    United States
    Messages: 1
    Status: Offline
    Hi, I'm new here, so I'm sorry if this question's already been answered.

    I've been able to run the program a few times, but now it doesn't work. When I click the icon it loads fine, but then it doesn't start. My taskbar has the icon which says it's running, but the window doesn't appear.

    Moved your post here and sent you a quick PM. Please attach your se.log file to help us assist you.
    DeathStarDate: Friday, 14.02.2014, 17:09 | Message # 309
    Group: Users
    Messages: 515
    Status: Offline
    Yup, I can now confirm that retrogade orbiting moons aren't generating. I just went to a gas giant with 76 moons, out of which 67 were outer irregular ones. I checked the inclination of every single one of them, and none were larger than 90 degrees. In fact, I ran into a few moons with 87 or 88 degrees of inclination, but never was it at 90 or above, so I am assuming that 90 degrees is some sort of limit. This is unrealistic, since around 85% of outer irregular moons should be in retrogarde orbit.
    SplitResonatorDate: Friday, 14.02.2014, 20:42 | Message # 310
    Group: Newbies
    United States
    Messages: 6
    Status: Offline
    I'm pretty new here I'm sorry if something like this seems redundant I've been learning SE but I've encountered some things that are bugging me.

    I can run this program fine on my gaming laptop 60 FPS etc etc it runs flawless, but when I try and run it on my Desktop/Main PC it crashes upon moving the mouse to look in different directions right after its done loading the planetarium.

    these are the specs on my main PC

    2 Intel Xeon's both at 3.20 GHz
    12 Gigs of RAM
    Windows 7 64-Bit
    Nvidia Quadro K6000 (this is a high end workstation card very powerful)
    1 TB Hardrive

    I have updated video card drivers etc etc and nothing is helping.

    and yet it wont even play on my computer without crashing upon looking around.
    if there's a fix for this that would be great, even if you guys cant help any information on something in my computer that would be causing crashes would be very helpful to.

    I'm not frustrated or anything I'm just boggled that it doesn't run on my main PC..
    WatsisnameDate: Friday, 14.02.2014, 23:21 | Message # 311
    Galaxy Architect
    Group: Global Moderators
    United States
    Messages: 2613
    Status: Offline
    Hey SplitResonator, sorry for your trouble. Your hardware definitely meets the recommended requirements so I don't think there's any problem there, but we'll have to see your se.log to see where/why this crash is occurring. Could you attach it please?

    jackiebeatle5Date: Saturday, 15.02.2014, 22:19 | Message # 312
    Group: Newbies
    Messages: 5
    Status: Offline
    I seem to have plenty of crashes lately on SpaceEngine. So, here is the story: First time running- runned fine until i went deep underwater and runtime error'd me. Second time running-Was messing around with the moon of the planet I start on (eg. turning it into a star, etc.) and it crashed after some time. Third time running- Just began, loaded a bit, screen turned black, after a few seconds it crashed, and TRASHED my desktop. In order to stop the glitch, I used CTRL+ALT+DEL to get rid of it. After a while of loading, Space Engine closed along with the error. This glitch is starting to get on my nerves. Anybody know how to fix this? I really want to continue playing this. sad

    Edited by jackiebeatle5 - Saturday, 15.02.2014, 22:19
    DeathStarDate: Saturday, 15.02.2014, 22:35 | Message # 313
    Group: Users
    Messages: 515
    Status: Offline
    You should have posted this in the general troublshooting and bug report thread. Also, you need to post your se.log file so it is understandable what exactly your problem is.
    karelmDate: Saturday, 15.02.2014, 23:14 | Message # 314
    Group: Newbies
    United States
    Messages: 7
    Status: Offline
    I get a crash a minute after everything has loaded successfully. I deleted the cache and restarted and same problem. Any ideas?

    Problem Event Name: APPCRASH
    Application Name: SpaceEngine.exe
    Application Version:
    Application Timestamp: 52bb3d6c
    Fault Module Name: nvoglv32.DLL
    Fault Module Version:
    Fault Module Timestamp: 52676a08
    Exception Code: c0000005
    Exception Offset: 00aeca93
    OS Version: 6.1.7601.
    Locale ID: 1033
    Additional Information 1: 0a9e
    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
    Additional Information 3: 0a9e
    Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

    Attachments: 1804281.log(44.8 Kb)

    Edited by karelm - Monday, 17.02.2014, 01:38
    HarbingerDawnDate: Saturday, 15.02.2014, 23:36 | Message # 315
    Cosmic Curator
    Group: Administrators
    United States
    Messages: 8717
    Status: Offline
    You need to attach your log. Read the opening post.

    All forum users, please read this!
    My SE mods and addons
    Phenom II X6 1090T 3.2 GHz, 16 GB DDR3 RAM, GTX 970 3584 MB VRAM
    Forum » SpaceEngine » Archive » Troubleshooting and bug reports - SpaceEngine