ENG New site

Advanced search

[ New messages · Forum rules · Members ]
Forum » SpaceEngine » Archive » Troubleshooting and bug reports - SpaceEngine
Troubleshooting and bug reports - SpaceEngine
SpaceEngineerDate: Thursday, 26.12.2013, 00:29 | Message # 1
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4800
Status: Offline
Please post here all of your reports about bugs or crashes in SpaceEngine. Before you post any bugs, please follow these steps:

  • Read the Fixing common issues section below. It is possible that your problem can be solved there.
  • Read the List of known issues section below and make sure that your bugs are not on in it. You can use your browser's word finder to help search the list.
  • If the bug is not on the list then please post it in this thread. Attach to your message a screenshot (if possible) and a log file (it's called the se.log and is located in the SpaceEngine/system/ directory). Only the log file will help me to understand your problem and find a solution!

    Fixing common issues

    1) Obsolete or incompatible drivers
    These are the most frequent errors found in SE. You will get a popup window with one of these following messages:

    - "You have old OpenGL version (2.1.1). Update your graphics card driver or install compatible hardware"

    - "You have old GLSL version (1.2). Update your graphics card driver or install compatible hardware"

    - "Critical extensions missing: GL_ARB_vertex_program GL_ARB_vertex_buffer_object"

    - "Error loading surface generator shaders. Press YES to run program with procedural planets disabled. Press NO to exit"

    Download and install latest drivers for your video card. If you still get this message, it could be that you have an incompatible video card (see next paragraph).

    [CRITICAL NOTE] Some recent NVidia drivers are incompatible with SE. Symptoms are flashing planet images on the screen when you open the F2 menu (see the spoiler), missing lens flares, grayed out options for HDR and FXAA in the Graphics settings menu, and other glitches. The errors in the se.log are look like this:

    If you have run into these problems, update to at least 344.65, or roll back to earlier than 337.xx.

    But you still can try and run SpaceEngine by disabling checking of critical errors at startup. Open main.cfg and change value of this parameter to 'true':

    IgnoreCriticalCheck true // ignore checking of OpenGL version and critical extensions supporting

    NOTE: I can give no guaranties that SpaceEngine will be stable and work correctly if you do make this change.

    If you have an "Error loading surface generator shaders" error and press Yes, SpaceEngine can run, but it will not be able to render procedural planetary landscapes.

    After updating or rollback of the drivers, you must delete the cache folder in the SpaceEngine directory.

    2) Weak system
    Most of the forum posts I receive are from users that report an inability to start SpaceEngine, This is because those users have inbuilt Intel graphics card, or some old GeForce 5700 series, or not a proper "gaming" laptop. There is no way but to update your hardware system. There are no plans to make a second version of the engine for weaker systems with simplified graphics, CPU texture generation, etc. It would be like coding another engine from scratch. Once again, I would remind everyone that the minimum system requirements can be found on the Home page, but I will mention it here as well:

    CPU 2.0 GHz
    RAM 2 Gb
    Video GeForce 8600, Radeon HD 2600
    vRAM 512 Mb

    I stress that the special role played by videocard onboard memory (vRAM). 512 MB is the absolute minimum. The engine uses a large amount of data that must be in video memory (textures, meshes, vbo, etc). If your system meets the recommended requirements, the engine will work, because its development is made for this hardware:

    CPU 3.0 GHz
    RAM 4 Gb
    Video GeForce 9800 GTX, ATI Mobility HD 5730
    vRAM 1024 Mb

    You can try to start the engine with some OpenGL extensions disabed, if your hardware does not support them: frame buffer objects (FBO), half floats, float textures and 3D textures. Information about this is written at the beginning of the log (SpaceEngine/system/se.log), after the list of extensions:

    Framebuffer objects supported
    Half floats suppoted
    Floating-point pixel format: GL_RGBA16F_ARB
    3D textures suppoted

    If the log reads 'unsupported, then the extension is not supported and the engine will disable itself. If it seems to support float and 3D textures, but the atmosphere of planets has some monstrous bottleneck, such as the GeForce 6200 and GeForce 6600, then it is best to disable those extensions forcibly. This is done in the file config/main.cfg:

    IgnoreFBO false // disable framebuffer objects
    IgnoreHalfFloat false // disable half floats
    IgnoreFloatTextures false // disable float textures
    Ignore3DTextures false // disable 3D textures
    IgnoreShaderBinary false // disable binary shaders cache
    IgnoreCriticalCheck false // ignore checking of OpenGL version and critical extensions supporting

    - The Milky Way and other nearby galaxies and nebulae use FBO. HDR rendering mode also use FBO. Disabling it disables the 3D models of galaxies and nebulae, and disables HDR mode.
    - Atmospheres using float and 3D textures. Disabling any of them disables the atmosphere. HDR rendering mode uses a float textures, disabling them disables HDR.
    - Shader binary cache reduces lags on loading shaders. Works normally on NVidia, onr ATI and Intel it disabled automatically after first laubch of SpaceEngine.

    If you have a Intel HD graphics card, it is better to disable asynchronous loading in the main.cfg as well:

    LoaderMode 2 // loader mode: 0 = immediate, 1 = interleaved, 2 = asynchronous

    3) System with hybrid graphics (NVidia/ATI + Intel HD)
    If you're running SE on a laptop with dual graphics, make sure SE runs on NVidia or ATI chip instead of Intel HD. You may see it in the beginning of "SpaceEngine/system/se.log" file. If it says:

    Vendor: Intel
    Renderer: Intel® HD Graphics 4000

    then you should open NVidia Control Panel or ATI Catalyst and force SpaceEngine.exe run on NVidia/ATI graphics card. If you do not found SpaceEngine profile there, create a new one.

    4) Crashing in the interstellar or intergalactic space or after appearing of the nebula in the view field
    If you open the "SpaceEngine/system/se.log" file after a crash, and it ends up with line like this:

    Creating nebula model "cache/models/nebulae/M42.nm",

    then try to disable asynchronous loading of a resources. Open the file config/main.cfg with the Notepad and change this parameter to 1:

    LoaderMode 1 // loader mode: 0 = immediate, 1 = interleaved, 2 = asynchronous

    After that, delete the cache folder from the SpaceEngine directory. Performance will drop while flying between a stars and galaxies, but stability may be improved. After a while, all models of galaxies and nebulae a being be generated, and you may enable asynchronous loading back (set up LoaderMode 2).

    5) Spaceship disappear when far from a star
    It is not a bug. Current version have not yet completed spaceships rendering system - they cannot be rendered if there is no stars or planets in the renderlist. Just imagine that ship becomes invisible in interstellar flight smile

    6) Blurry textures on Solar system planets
    It is not a bug. Our Solar system planets (Mercury, Venus, Earth, Moon, Mars, Jupiter, Saturn, Uranus, Neptune and its satellites) have no procedural textures, only real ones with limited level-of-detail. You can download addons with high resolution textures to increase level of detail of real planets.

    7) Artifacts on procedural planets
    If you get missing landscape blocks, blurry or blinking textures, random spikes sticking out of surface, check out these recommendations here:

    a) If you have a laptop with hybrid graphics, read the paragraph 3.

    b) Make sure that you make a "clean" installation of SE. If you install a new version overwriting the old one, you may get many bugs and glitches. If you get some glitches after the patch is installed, remove the folder called cache from SpaceEngine's directory.

    c) If this does not help, read the paragraph 8.

    8) Frequent crashing while generating planetary surface
    If you have frequent crashes on planets, or get an "OUT OF MEMORY" message on screen, or "Unexpected deleting of child node" in the log file, try taking these steps first:

  • Close any other programs that can consume the video memory (games, video players, graphics editors, etc.). SpaceEngine is not a small flash type game, video memory is the most important resource for it. It may help to disable the Windows Aero theme too, as it consumes a lot of video memory.
  • Disable "3D water" in Graphics settings (Ctrl-F4)
  • Reduce "Landscape LOD" to -2 in Graphics settings (Ctrl+F4)
  • Set up the amount of video memory in the main.cfg file:

    VideoMemorySize 2048 // video card onboard memory (VRAM) in megabytes

    The value must not be less than 1024, but not more than the total amount of physical video memory plus amount of RAM. For example, if you have a graphics card with 1024 MB of video memory, and more than 2 GB of RAM, you can increase VideoMemorySize to 2048.

    List of known issues

    Green items have been fixed for the next release

    Not real bugs, but effects caused by limitations in the engine:
    - Ships do not render in interstellar space
    - Star catalog has many errors in star classification, so there are many "giant dwarfs" and "dwarf giants"
    - Many real binary stars rendered as single, and many single rendered as binary - SE simply have incomplete catalog of binary stars
    - An unwanted star (sprite) is visible in the barycenter of a binary star from distance greater than 0.01 pc
    - Comet nucleus star-sprite will shine through planets [example].
    - Galaxy/nebula sprites will rotate when seen from certain angles
    - Auroras, comet tails and rings can be rendered in front of ships/moons sometimes
    - Lens flares are distorted by gravitational lensing (black holes and ship warp drive effect)
    - Text editor for Wiki descriptions is not working - it is not implemented yet
    - Solar system moons don't have extremely accurate orbits (requires implementation of custom orbit models, e.g. VSOP-87)
    - Sunspot distribution is not always realistic
    - Ocean tag not yet implemented in planet editor
    - Rounding errors (e.g. 30° in catalog rounds to 29°59'59.99" displayed on HUD)
    - Ship retro engines have not been implemented yet

    Real bugs:
    - Too many planets with life (panspermia issue)
    - Oceanias have landscapes above water
    - Several bugs with the planet editor
    - Changing "modes" between simulation and orbital when piloting ships can cause glitches
    - Few issues with asynchronous loading (stars don't always generate properly, especially when flying to new galaxies)
    - Holes in some giant stars when camera is directly above a very tall spot [example]
    - Flashing landscape LOD on a planet when Wiki for it is displayed
    - Star clusters not displayed in Wiki
    - GUI response issues with some users (interface items glitchy or not respond easily)
    - GUI toolbars may completely disappear when pressing pin button while half-hidden
    - Deep space objects (e.g. stars, galaxies) will shine through planets when HDR for DSO is off, but HDR is on and Bloom is on [example]
    - Some neutron stars can have very low temperatures [example]
    - Flickering flare color in close binary systems [example]
    - Auto-exposure does not react when a sun is blocked while diffraction spikes are set to normal or super
    - Planet rings have an unrealistic color palette
    - "Eclipse bug" on distant planets (weird dark shimmering on outer planet caused by inner planet crossing the sun or two suns eclipsing)
    - Cloud cyclones have cut edges sometimes
    - Level horizon command (End key) doesn't work properly on oblate objects
    - Problems when releasing Left + Right click
    - Lines or junctures are visible on planetary surface
    - Switching to fullscreen doesn't work sometimes
    - Weird behavior of movement keys in tracking mode (T) and after releasing it
    - Automatic reference object setting with spacecraft doesn't always choose the best object (for example, when near dwarf moons or debris asteroids close to a planet you are trying to orbit)
    - 3D water fog sometimes starts above the water surface
    - Problems with the skybox export interface, and with the planetarium after using it, for some users
    - Music player will unpause when SE window is minimized and restored, or when entering and exiting the main menu
    - If a galaxy model is selected, the camera is not following any object, and the program is in Edit Mode, closing and restarting the program will cause the WASDRF movement keys to behave incorrectly until the camera is set to follow an object
    - "Crop orbits" in the Map mode doesn't work
    - Spaceship and lens flare textures do not load when loader mode is set to "Immediate"
    - Visual atmosphere heights are inconsistently and unrealistically generated
    - Physical atmosphere properties are inconsistently and unrealistically generated, and are not tied to the visual models
    - Dwarf moons can be generated on colliding orbits
    - Moons are never generated with retrograde orbits
    - Bugs with the surfaces of carbon stars and zirconium stars
    - Cyclones are not generated in the southern hemispheres of gas giants
    - Sometimes, worlds which are too small are classed as "selena" when they should be classed as asteroid
    - Shimmering bloom splotch when very close to the surface of a planet [example]
    - CW/CCW rotation keys for ship in atmosphere are reversed
    - Mouse axis inversion settings for spaceship controls are not saved
    - Z faces are switched when exporting skyboxes (pos_Z is really neg_Z)
    HarbingerDawnDate: Thursday, 26.12.2013, 15:03 | Message # 16
    Cosmic Curator
    Group: Administrators
    United States
    Messages: 8717
    Status: Offline
    Quote Billy_Mayes ()
    I added a folder named "screenshots" but it didn't help at all.

    Something must be wrong with your installation. Reinstall.

    All forum users, please read this!
    My SE mods and addons
    Phenom II X6 1090T 3.2 GHz, 16 GB DDR3 RAM, GTX 970 3584 MB VRAM
    spacerDate: Thursday, 26.12.2013, 16:15 | Message # 17
    Star Engineer
    Group: Users
    Messages: 1258
    Status: Offline
    strange clouds
    Attachments: 1188879.jpg(262.6 Kb)

    "we began as wanderers, and we are wanderers still"
    -carl sagan

    -space engine photographer
    apenpaapDate: Thursday, 26.12.2013, 17:13 | Message # 18
    World Builder
    Group: Users
    Messages: 1063
    Status: Offline
    It's more of an oversight than a bug, but the music player seems to always assume you use a 45 degree FOV. I usually have my FOV on 22 degrees, and I've noticed I need to get really close to planets before the music player switches to the correct track.

    I occasionally stream at http://www.twitch.tv/magistermystax. Sometimes SE, sometimes other games.
    Billy_MayesDate: Thursday, 26.12.2013, 17:41 | Message # 19
    Group: Users
    Messages: 485
    Status: Offline
    Quote HarbingerDawn ()
    Something must be wrong with your installation. Reinstall.

    This is weird, it doesn't help. When I try to take a screenshot,
    Space Engine says screenshot/001 saved, but they are nowhere to be found.

    I've tried the google drive and the torrent magnet URL, but they both just seem to not install the screenshots folder.
    Here's a picture of my Space Engine 0.971. folder.

    AMD Phenom II X4 955 3.2 GHz Quad-Core - AMD Radeon HD 6950 2GB VRAM - 4GB RAM - 1680x1050 75 Hz Samsung screen

    Edited by Billy_Mayes - Thursday, 26.12.2013, 17:42
    SaaanDate: Thursday, 26.12.2013, 18:03 | Message # 20
    Group: Users
    Messages: 17
    Status: Offline
    oceanic world with islands:

    Attachments: 3850608.jpg(513.9 Kb)
    midtskogenDate: Thursday, 26.12.2013, 19:06 | Message # 21
    Star Engineer
    Group: Users
    Messages: 1674
    Status: Offline
    An example of tiling:

    It gets worse on the surface and it's 100% reproduceable after a few minutes of playing, it seems. I saw such things in 0.97 as well, but not that soon. It's usually a precursor to a crash. SE can run fine for hours if I stand still, but I don't think I've been able to run SE for more than 15 minutes actively.

    For me 0.96 is by far the most stable version. sad

    Attachments: 3227163.jpg(566.0 Kb)

    SaaanDate: Thursday, 26.12.2013, 19:08 | Message # 22
    Group: Users
    Messages: 17
    Status: Offline
    did you try this?

    Quote Voekoevaka ()
    Disable VideoMemoryDynamicDetect on main.cfg to fix your bug 3. You have low VRAM.

    You'll get a bit more crashes but those annoying loading bugs will dissapear.
    midtskogenDate: Thursday, 26.12.2013, 21:03 | Message # 23
    Star Engineer
    Group: Users
    Messages: 1674
    Status: Offline
    It detects 2048 MB of VRAM, which is correct, but setting 2048 explicitly didn't make any difference.

    Quote se.log
    Vendor: NVIDIA Corporation
    Renderer: GeForce GTX 670/PCIe/SSE2
    OpenGL version: 4.2.0 NVIDIA 304.88
    GLSL version: 4.20 NVIDIA via Cg compiler
    Number of CPUs: 8
    Loader threads: 7
    RAM granularty: 4 kb
    Total RAM: 4095 Mb
    Available RAM: 4095 Mb
    Total VRAM: 2048 Mb
    Available VRAM: 1147 Mb
    Dedicated VRAM: 2048 Mb (from main.cfg)

    Apart from incorrect RAM (I have 16GB + 16GB swap), does this look sensible?

    Added (27.12.2013, 00:03)
    A sure way for me to break rendering and crash SE is to park in orbit altitude, zoom far in to get landscape details, speed up time and take a break for a few minutes. Result:

    And soon everything crashes.

    Perhaps it has something to do with landscape generation. It goes well for a time, but leads to corruption eventually. I've played with setting VRAM to lower values, but that doesn't help.

    Attachments: 3429217.jpg(319.0 Kb)


    Edited by midtskogen - Thursday, 26.12.2013, 21:03
    neutronium76Date: Thursday, 26.12.2013, 21:55 | Message # 24
    World Builder
    Group: Users
    Messages: 718
    Status: Offline
    Quote midtskogen ()
    Apart from incorrect RAM (I have 16GB + 16GB swap)

    SE can only ''see'' a max of 4GBs of RAM as it is a 32bit app.
    The trick I think (but I maybe wrong) is to find a nice balance between VRAM available to SE and RAM.
    If you have a 2GB VrAM and 16GB RAM you want to aim for a total memory consumption not exceeding 4gigs. So VRAM nust be somewhere between 1 and 2GBs available to SE so set VRAM detection to true and MAX VRAM consumption to around 75%.
    Generally speaking SE consumes about equal amounts of VRAM and RAM if you set it to use your true VRAM. So you would not want to make it consume more than 3-3.5 gigs of total VRAM and RAM as it will reach its 32bit limitation.
    For those with little VRAM (less than 1GB or even less then 512MB) you have to set auto detection to false in main.cfg and give RAM to be used as VRAM. Again the same rule applies: Total VRAM+RAM must be less then 4-3.5GBs

    PC1:Core i7 [email protected], 6 cores/12 threads, 12GB DDR3 [email protected], 2x(SLI) GTX-580 GPUs 3GB VRAM(GDDR5)@1GHz, OS:Win7x64SP1
    PC2:Core2Quad [email protected], 2 cores/4 threads 4GB DDR2 [email protected], GTX-285 GPU 1GB VRAM(DDR3)@1.24GHz, OS:WinVistax64SP2

    Edited by neutronium76 - Thursday, 26.12.2013, 21:59
    HarbingerDawnDate: Thursday, 26.12.2013, 22:41 | Message # 25
    Cosmic Curator
    Group: Administrators
    United States
    Messages: 8717
    Status: Offline
    Quote midtskogen ()
    For me 0.96 is by far the most stable version.

    For me, 0.970 was most stable and 0.971 has best performance.

    All forum users, please read this!
    My SE mods and addons
    Phenom II X6 1090T 3.2 GHz, 16 GB DDR3 RAM, GTX 970 3584 MB VRAM
    DeathStarDate: Thursday, 26.12.2013, 23:26 | Message # 26
    Group: Users
    Messages: 515
    Status: Offline
    Not sure if this is exactly a bug or not, but I have found tons of deserts with unicellular life that have vegetation on the surface.
    HarbingerDawnDate: Thursday, 26.12.2013, 23:51 | Message # 27
    Cosmic Curator
    Group: Administrators
    United States
    Messages: 8717
    Status: Offline
    Quote DeathStar ()
    Not sure if this is exactly a bug or not, but I have found tons of deserts with unicellular life that have vegetation on the surface.

    That is not a bug.

    All forum users, please read this!
    My SE mods and addons
    Phenom II X6 1090T 3.2 GHz, 16 GB DDR3 RAM, GTX 970 3584 MB VRAM
    KingbastardDate: Friday, 27.12.2013, 00:57 | Message # 28
    Group: Newbies
    Messages: 3
    Status: Offline
    Change Reference button (Default 'P') has no effect at all in 0.971, am i missing something? Changing reference was useful when you didnt want to reference the closest object, for example Mars when near Phobos.
    DeathStarDate: Friday, 27.12.2013, 01:34 | Message # 29
    Group: Users
    Messages: 515
    Status: Offline

    I think the picture explains it all.

    Added (27.12.2013, 04:34)
    By the way, the moon itself is rendered normally(just an ordinary irregular asteroid).

    Attachments: 6358471.jpg(277.8 Kb)
    TritonClawDate: Friday, 27.12.2013, 02:00 | Message # 30
    Space Tourist
    Group: Users
    Messages: 21
    Status: Offline
    In the Map Screen (F1), when I double click on an object to center it, the screen sort of freezes, not allowing me to rotate or move to another object, and the red distance numbers flicker, but never seem to exceed a few hundred meters.

    EDIT: Also there is a clearly asteroidal body (RS 8409-2742-8-4322219-13 A5.1) That is listed as a "Cold Selena"

    Edited by TritonClaw - Friday, 27.12.2013, 02:04
    Forum » SpaceEngine » Archive » Troubleshooting and bug reports - SpaceEngine