ENG New site

Advanced search

[ New messages · Forum rules · Members ]
Forum » SpaceEngine » Archive » Troubleshooting and bug reports - SpaceEngine
Troubleshooting and bug reports - SpaceEngine
SpaceEngineerDate: Thursday, 26.12.2013, 00:29 | Message # 1
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4800
Status: Offline
Please post here all of your reports about bugs or crashes in SpaceEngine. Before you post any bugs, please follow these steps:

  • Read the Fixing common issues section below. It is possible that your problem can be solved there.
  • Read the List of known issues section below and make sure that your bugs are not on in it. You can use your browser's word finder to help search the list.
  • If the bug is not on the list then please post it in this thread. Attach to your message a screenshot (if possible) and a log file (it's called the se.log and is located in the SpaceEngine/system/ directory). Only the log file will help me to understand your problem and find a solution!

    Fixing common issues

    1) Obsolete or incompatible drivers
    These are the most frequent errors found in SE. You will get a popup window with one of these following messages:

    - "You have old OpenGL version (2.1.1). Update your graphics card driver or install compatible hardware"

    - "You have old GLSL version (1.2). Update your graphics card driver or install compatible hardware"

    - "Critical extensions missing: GL_ARB_vertex_program GL_ARB_vertex_buffer_object"

    - "Error loading surface generator shaders. Press YES to run program with procedural planets disabled. Press NO to exit"

    Download and install latest drivers for your video card. If you still get this message, it could be that you have an incompatible video card (see next paragraph).

    [CRITICAL NOTE] Some recent NVidia drivers are incompatible with SE. Symptoms are flashing planet images on the screen when you open the F2 menu (see the spoiler), missing lens flares, grayed out options for HDR and FXAA in the Graphics settings menu, and other glitches. The errors in the se.log are look like this:

    If you have run into these problems, update to at least 344.65, or roll back to earlier than 337.xx.

    But you still can try and run SpaceEngine by disabling checking of critical errors at startup. Open main.cfg and change value of this parameter to 'true':

    IgnoreCriticalCheck true // ignore checking of OpenGL version and critical extensions supporting

    NOTE: I can give no guaranties that SpaceEngine will be stable and work correctly if you do make this change.

    If you have an "Error loading surface generator shaders" error and press Yes, SpaceEngine can run, but it will not be able to render procedural planetary landscapes.

    After updating or rollback of the drivers, you must delete the cache folder in the SpaceEngine directory.

    2) Weak system
    Most of the forum posts I receive are from users that report an inability to start SpaceEngine, This is because those users have inbuilt Intel graphics card, or some old GeForce 5700 series, or not a proper "gaming" laptop. There is no way but to update your hardware system. There are no plans to make a second version of the engine for weaker systems with simplified graphics, CPU texture generation, etc. It would be like coding another engine from scratch. Once again, I would remind everyone that the minimum system requirements can be found on the Home page, but I will mention it here as well:

    CPU 2.0 GHz
    RAM 2 Gb
    Video GeForce 8600, Radeon HD 2600
    vRAM 512 Mb

    I stress that the special role played by videocard onboard memory (vRAM). 512 MB is the absolute minimum. The engine uses a large amount of data that must be in video memory (textures, meshes, vbo, etc). If your system meets the recommended requirements, the engine will work, because its development is made for this hardware:

    CPU 3.0 GHz
    RAM 4 Gb
    Video GeForce 9800 GTX, ATI Mobility HD 5730
    vRAM 1024 Mb

    You can try to start the engine with some OpenGL extensions disabed, if your hardware does not support them: frame buffer objects (FBO), half floats, float textures and 3D textures. Information about this is written at the beginning of the log (SpaceEngine/system/se.log), after the list of extensions:

    Framebuffer objects supported
    Half floats suppoted
    Floating-point pixel format: GL_RGBA16F_ARB
    3D textures suppoted

    If the log reads 'unsupported, then the extension is not supported and the engine will disable itself. If it seems to support float and 3D textures, but the atmosphere of planets has some monstrous bottleneck, such as the GeForce 6200 and GeForce 6600, then it is best to disable those extensions forcibly. This is done in the file config/main.cfg:

    IgnoreFBO false // disable framebuffer objects
    IgnoreHalfFloat false // disable half floats
    IgnoreFloatTextures false // disable float textures
    Ignore3DTextures false // disable 3D textures
    IgnoreShaderBinary false // disable binary shaders cache
    IgnoreCriticalCheck false // ignore checking of OpenGL version and critical extensions supporting

    - The Milky Way and other nearby galaxies and nebulae use FBO. HDR rendering mode also use FBO. Disabling it disables the 3D models of galaxies and nebulae, and disables HDR mode.
    - Atmospheres using float and 3D textures. Disabling any of them disables the atmosphere. HDR rendering mode uses a float textures, disabling them disables HDR.
    - Shader binary cache reduces lags on loading shaders. Works normally on NVidia, onr ATI and Intel it disabled automatically after first laubch of SpaceEngine.

    If you have a Intel HD graphics card, it is better to disable asynchronous loading in the main.cfg as well:

    LoaderMode 2 // loader mode: 0 = immediate, 1 = interleaved, 2 = asynchronous

    3) System with hybrid graphics (NVidia/ATI + Intel HD)
    If you're running SE on a laptop with dual graphics, make sure SE runs on NVidia or ATI chip instead of Intel HD. You may see it in the beginning of "SpaceEngine/system/se.log" file. If it says:

    Vendor: Intel
    Renderer: Intel® HD Graphics 4000

    then you should open NVidia Control Panel or ATI Catalyst and force SpaceEngine.exe run on NVidia/ATI graphics card. If you do not found SpaceEngine profile there, create a new one.

    4) Crashing in the interstellar or intergalactic space or after appearing of the nebula in the view field
    If you open the "SpaceEngine/system/se.log" file after a crash, and it ends up with line like this:

    Creating nebula model "cache/models/nebulae/M42.nm",

    then try to disable asynchronous loading of a resources. Open the file config/main.cfg with the Notepad and change this parameter to 1:

    LoaderMode 1 // loader mode: 0 = immediate, 1 = interleaved, 2 = asynchronous

    After that, delete the cache folder from the SpaceEngine directory. Performance will drop while flying between a stars and galaxies, but stability may be improved. After a while, all models of galaxies and nebulae a being be generated, and you may enable asynchronous loading back (set up LoaderMode 2).

    5) Spaceship disappear when far from a star
    It is not a bug. Current version have not yet completed spaceships rendering system - they cannot be rendered if there is no stars or planets in the renderlist. Just imagine that ship becomes invisible in interstellar flight smile

    6) Blurry textures on Solar system planets
    It is not a bug. Our Solar system planets (Mercury, Venus, Earth, Moon, Mars, Jupiter, Saturn, Uranus, Neptune and its satellites) have no procedural textures, only real ones with limited level-of-detail. You can download addons with high resolution textures to increase level of detail of real planets.

    7) Artifacts on procedural planets
    If you get missing landscape blocks, blurry or blinking textures, random spikes sticking out of surface, check out these recommendations here:

    a) If you have a laptop with hybrid graphics, read the paragraph 3.

    b) Make sure that you make a "clean" installation of SE. If you install a new version overwriting the old one, you may get many bugs and glitches. If you get some glitches after the patch is installed, remove the folder called cache from SpaceEngine's directory.

    c) If this does not help, read the paragraph 8.

    8) Frequent crashing while generating planetary surface
    If you have frequent crashes on planets, or get an "OUT OF MEMORY" message on screen, or "Unexpected deleting of child node" in the log file, try taking these steps first:

  • Close any other programs that can consume the video memory (games, video players, graphics editors, etc.). SpaceEngine is not a small flash type game, video memory is the most important resource for it. It may help to disable the Windows Aero theme too, as it consumes a lot of video memory.
  • Disable "3D water" in Graphics settings (Ctrl-F4)
  • Reduce "Landscape LOD" to -2 in Graphics settings (Ctrl+F4)
  • Set up the amount of video memory in the main.cfg file:

    VideoMemorySize 2048 // video card onboard memory (VRAM) in megabytes

    The value must not be less than 1024, but not more than the total amount of physical video memory plus amount of RAM. For example, if you have a graphics card with 1024 MB of video memory, and more than 2 GB of RAM, you can increase VideoMemorySize to 2048.

    List of known issues

    Green items have been fixed for the next release

    Not real bugs, but effects caused by limitations in the engine:
    - Ships do not render in interstellar space
    - Star catalog has many errors in star classification, so there are many "giant dwarfs" and "dwarf giants"
    - Many real binary stars rendered as single, and many single rendered as binary - SE simply have incomplete catalog of binary stars
    - An unwanted star (sprite) is visible in the barycenter of a binary star from distance greater than 0.01 pc
    - Comet nucleus star-sprite will shine through planets [example].
    - Galaxy/nebula sprites will rotate when seen from certain angles
    - Auroras, comet tails and rings can be rendered in front of ships/moons sometimes
    - Lens flares are distorted by gravitational lensing (black holes and ship warp drive effect)
    - Text editor for Wiki descriptions is not working - it is not implemented yet
    - Solar system moons don't have extremely accurate orbits (requires implementation of custom orbit models, e.g. VSOP-87)
    - Sunspot distribution is not always realistic
    - Ocean tag not yet implemented in planet editor
    - Rounding errors (e.g. 30° in catalog rounds to 29°59'59.99" displayed on HUD)
    - Ship retro engines have not been implemented yet

    Real bugs:
    - Too many planets with life (panspermia issue)
    - Oceanias have landscapes above water
    - Several bugs with the planet editor
    - Changing "modes" between simulation and orbital when piloting ships can cause glitches
    - Few issues with asynchronous loading (stars don't always generate properly, especially when flying to new galaxies)
    - Holes in some giant stars when camera is directly above a very tall spot [example]
    - Flashing landscape LOD on a planet when Wiki for it is displayed
    - Star clusters not displayed in Wiki
    - GUI response issues with some users (interface items glitchy or not respond easily)
    - GUI toolbars may completely disappear when pressing pin button while half-hidden
    - Deep space objects (e.g. stars, galaxies) will shine through planets when HDR for DSO is off, but HDR is on and Bloom is on [example]
    - Some neutron stars can have very low temperatures [example]
    - Flickering flare color in close binary systems [example]
    - Auto-exposure does not react when a sun is blocked while diffraction spikes are set to normal or super
    - Planet rings have an unrealistic color palette
    - "Eclipse bug" on distant planets (weird dark shimmering on outer planet caused by inner planet crossing the sun or two suns eclipsing)
    - Cloud cyclones have cut edges sometimes
    - Level horizon command (End key) doesn't work properly on oblate objects
    - Problems when releasing Left + Right click
    - Lines or junctures are visible on planetary surface
    - Switching to fullscreen doesn't work sometimes
    - Weird behavior of movement keys in tracking mode (T) and after releasing it
    - Automatic reference object setting with spacecraft doesn't always choose the best object (for example, when near dwarf moons or debris asteroids close to a planet you are trying to orbit)
    - 3D water fog sometimes starts above the water surface
    - Problems with the skybox export interface, and with the planetarium after using it, for some users
    - Music player will unpause when SE window is minimized and restored, or when entering and exiting the main menu
    - If a galaxy model is selected, the camera is not following any object, and the program is in Edit Mode, closing and restarting the program will cause the WASDRF movement keys to behave incorrectly until the camera is set to follow an object
    - "Crop orbits" in the Map mode doesn't work
    - Spaceship and lens flare textures do not load when loader mode is set to "Immediate"
    - Visual atmosphere heights are inconsistently and unrealistically generated
    - Physical atmosphere properties are inconsistently and unrealistically generated, and are not tied to the visual models
    - Dwarf moons can be generated on colliding orbits
    - Moons are never generated with retrograde orbits
    - Bugs with the surfaces of carbon stars and zirconium stars
    - Cyclones are not generated in the southern hemispheres of gas giants
    - Sometimes, worlds which are too small are classed as "selena" when they should be classed as asteroid
    - Shimmering bloom splotch when very close to the surface of a planet [example]
    - CW/CCW rotation keys for ship in atmosphere are reversed
    - Mouse axis inversion settings for spaceship controls are not saved
    - Z faces are switched when exporting skyboxes (pos_Z is really neg_Z)
    spacerDate: Saturday, 18.01.2014, 13:41 | Message # 211
    Star Engineer
    Group: Users
    Messages: 1258
    Status: Offline
    this is a bug or this can happend?
    (the life!!!)

    Attachments: 2639043.jpg(307.8 Kb)

    "we began as wanderers, and we are wanderers still"
    -carl sagan

    -space engine photographer

    Edited by spacer - Saturday, 18.01.2014, 13:43
    HarbingerDawnDate: Saturday, 18.01.2014, 13:46 | Message # 212
    Cosmic Curator
    Group: Administrators
    United States
    Messages: 8717
    Status: Offline
    Of course it can happen

    All forum users, please read this!
    My SE mods and addons
    Phenom II X6 1090T 3.2 GHz, 16 GB DDR3 RAM, GTX 970 3584 MB VRAM
    spacerDate: Saturday, 18.01.2014, 13:49 | Message # 213
    Star Engineer
    Group: Users
    Messages: 1258
    Status: Offline
    Quote HarbingerDawn ()
    Of course it can happen

    the first time i see that.

    "we began as wanderers, and we are wanderers still"
    -carl sagan

    -space engine photographer
    apenpaapDate: Saturday, 18.01.2014, 13:51 | Message # 214
    World Builder
    Group: Users
    Messages: 1063
    Status: Offline

    Oh wow, never seen that before surprised It doesn't look like a bug to me, though, just something incredibly rare: two chemically distinct biospheres evolving on the same planet, one below the ice and one on the surface.

    I occasionally stream at http://www.twitch.tv/magistermystax. Sometimes SE, sometimes other games.
    lzepplin1975Date: Saturday, 18.01.2014, 22:10 | Message # 215
    Group: Newbies
    United States
    Messages: 7
    Status: Offline
    My FXAA antialiasing option all of a sudden is unsupported. How do I fix this?
    HarbingerDawnDate: Saturday, 18.01.2014, 22:54 | Message # 216
    Cosmic Curator
    Group: Administrators
    United States
    Messages: 8717
    Status: Offline
    Quote lzepplin1975 ()
    My FXAA antialiasing option all of a sudden is unsupported. How do I fix this?

    Did you for some reason turn HDR off? If so, turn it back on as SE doesn't work properly without it, and gets worse performance with it off.

    All forum users, please read this!
    My SE mods and addons
    Phenom II X6 1090T 3.2 GHz, 16 GB DDR3 RAM, GTX 970 3584 MB VRAM
    lzepplin1975Date: Saturday, 18.01.2014, 22:58 | Message # 217
    Group: Newbies
    United States
    Messages: 7
    Status: Offline
    Yes its on. I turn it off and then back on again and the FXAA option lights up but when I click to activate it, it says "FXAA antialiasing is unsupported" and goes dark again. I've already reinstalled the game twice and it still wont work.
    DmanDate: Sunday, 19.01.2014, 01:23 | Message # 218
    Group: Newbies
    United States
    Messages: 2
    Status: Offline
    I just recently discovered space engine; I'm really impressed by the quality of its procedural generator. Although I did find some bugs after messing with the main.cfg file (so these bugs aren't really important). For example when increasing some of the planet settings, the engine will start to spit out some weird height maps that cause the textures to band between the cliff and flat texture.
    here's a picture of it:

    here is my planet settings from main.cfg:

    PlanetMipMapping      false    // use mipmapping for landscape textures
    PlanetTextureRes      512    // texture resolution (use only power of 2!)
    PlanetTextureBorder   1  // texture border
    PlanetHeightmapFormat 13    // format of the heightmap textures
    PlanetSphereMeshLOD   4  // spherical mesh detail
    PlanetCubeMeshLOD     4  // landscape mesh detail
    PlanetRingsSubdiv     16    // planetary rings detail
    PlanetCloudsTerra     12    // max number of cloud layers for terrestrial planets
    PlanetCloudsGasGiant  24    // max number of cloud layers for gas giant planets
    PlanetDetailCraters   3.0    // approx. min radius of craters on terrestrial planets (kilometers)
    PlanetDetailTerra     0.001    // approx. per vertex detail on terrestrial planets (kilometers)
    PlanetDetailClouds    0.02    // approx. per vertex detail on clouds (kilometers)
    PlanetDetailGasGiant  1.0    // approx. per vertex detail on gas giant planets (kilometers)
    PlanetDetailSun       1.0    // approx. per vertex detail on stars surface (kilometers)
    PlanetDetailTexScale  65536 // scale of detail textures
    PlanetDetailTextures  true    // use detail noise textures (remove cache to apply changes)

    also I have increased my vram to 4096 and set auto detect to false.

    Another "bug" (reading around I assume it has to do with memory limitations) is that the engine becomes very unstable at high resolutions while recording.
    VoekoevakaDate: Sunday, 19.01.2014, 01:41 | Message # 219
    World Builder
    Group: SE team
    Messages: 1016
    Status: Offline
    Not a bug.

    Due to a lack of presicion, the shaders are not designed to generate too much detail, so forcing these to have too much detail create weird patterns.

    Want some music of mine ? Please go here !

    lzepplin1975Date: Sunday, 19.01.2014, 04:33 | Message # 220
    Group: Newbies
    United States
    Messages: 7
    Status: Offline
    I figured out my problem. For some reason my computer didn't set the default graphics card to my NVIDIA card. I've been doing some updating and disk cleaning and that my have caused the problem. Problem fixed.
    Atheist101Date: Sunday, 19.01.2014, 05:38 | Message # 221
    Group: Users
    United States
    Messages: 47
    Status: Offline
    I have been having an issue with the star browser function. If I leave it searching for long enough it crashes SE. I like to start a search find a good system and look through it. Then come back the the browser and let it search some more. Then look again. If its searching for a large number is stars after it loads a while it will crash. So far its only happened when the window is open that I have noticed.
    fmraDate: Sunday, 19.01.2014, 08:58 | Message # 222
    Group: Newbies
    United States
    Messages: 2
    Status: Offline
    I think this is a bug... I've been playing with the wiki, manually entering information and importing changes back into the game. SE seems to import a different version of the wiki (from numerous saves of dbcfg) everytime I click import. It should only be reading the current db.cfg save, no? Looked for a cache everywhere in the SE folder and found nothing. Any idea how I could not have it load outdated versions when I import db.cfg?
    HarbingerDawnDate: Sunday, 19.01.2014, 16:52 | Message # 223
    Cosmic Curator
    Group: Administrators
    United States
    Messages: 8717
    Status: Offline
    I don't know. I always edit the database file manually, besides naming the planet, since it's much less complicated that way. Anyway, one day a text editor will be integrated into the wiki, making all of this irrelevant.

    All forum users, please read this!
    My SE mods and addons
    Phenom II X6 1090T 3.2 GHz, 16 GB DDR3 RAM, GTX 970 3584 MB VRAM
    JCandeiasDate: Sunday, 19.01.2014, 17:47 | Message # 224
    Group: Translators
    Messages: 387
    Status: Offline
    Quote Voekoevaka ()
    Due to a lack of presicion, the shaders are not designed to generate too much detail, so forcing these to have too much detail create weird patterns.

    ... which I actually like, especially in terras with life, because they have some common characteristics with structures generated by living organisms. I'm thinking, for instance, in those vast fields of termite nests found in Australian or African arid areas.

    They let me use this!
    ZamachiDate: Tuesday, 21.01.2014, 20:54 | Message # 225
    Group: Newbies
    Messages: 9
    Status: Offline
    I've downloaded SE and everything went fine, explored a bit and so...
    Next day I run it and when I double-tapped G to fly fast to some star, SE just froze and after couple of seconds it crashed.(But it doesn't happen with slower travel, a.k.a 'one-tapped g')
    Also, when I reach the destination and I look around it, the SE freezes and it crashes, same like with fast travel.

    And about looking a celestial body from the ground, sometimes music just goes 'talala, ta-ta-ta-ta-ta', changing the PoV makes the music go on, but when I stop again it goes again that way.(It even happened that the music totally stops and doesn't start again)

    I've added my SE.log in case it's needed.

    Keep up with the good work, SE's gonna be a hit!

    Attachments: 0673171.log(28.0 Kb)
    Forum » SpaceEngine » Archive » Troubleshooting and bug reports - SpaceEngine